iPad mini 2 using iOS 12.5.3 can't connect to Internet

Two days ago I updated my iPad Mini 2 to 12.5.3. Now I cannot connect to the internet. The iPad connects to my router, but every site times out and either reports the server stopped responding, or that it’s not connected to the internet. There are no error messages in settings that there is no internet. I have tried powering on and off, resetting network settings (multiple times) rebooting router. all my other devices work fine with wifi; a similar iPad Mini 2 with 12.5.2 connects. If I use my iPhone’s hotspot, the iPad connects to the internet just fine. This may be coincidence regarding 12.5.3 update, but I’ve checked every setting on wifi and it all seems correct. Short of wiping the iPad and reinstalling from an iCloud backup (that was prior to 12.5.3 update), have I missed something?


  • Go to Settings > Wi-Fi
  • Select you WiFi network
  • Tap the info button
  • Tap Forget This Network
  • Back out and re-add the network.

This will, among other things, force reset the DNS settings which can cause symptoms as described by you.

1 Like

Thanks, James. Unfortunately that did not work. Same issue.

I went further and restored the iPad using Catalina, but still can’t connect to internet. I reset all settings in General > Reset all Settings, no change.

When I try to restore my iCloud backup using a hotspot from my phone, it goes for a minute or so, then says" Lost Network Connection…not connected to internet" even though it’s still connected to my hotspot.

So at this time, I have none of my data or internet wifi connectivity. I wonder if a lightning-ethernet adapter would work. If I restore my iCloud backup, does it restore 12.5.2 with it?

A long shot, but try assigning a static IP address via the router’s settings. That resolved an internet connection issue I was having with a Homepod.
Otherwise it sounds like either the iPad or the router is blocking a port that is needed for internet connection - but it is strange that it started with a software update.

No, the backup only contains data. Sometimes wiping and restoring fixed weird problems like this, though.

Similar to what James suggested, you could try setting DNS manually in the WiFi settings on the iPhone iPad rather than using automatic. Settings / WiFi, tap the info button for your WiFi, scroll down a bit to Configure DNS. You can try Google’s dns at and or CloudFlare’s at and and see if charging dns servers help.

If you are seeing this only in Safari, you can try nuking the Safari history and cache with settings / safari / clear history and website data (I believe that was still the command in iOS 12). This will lose all of your login cookies so reconnecting to web sites will require logging in to the sites again for those that require it, but a step worth trying.

Thanks, Michael and Doug. No joy. The iPad connects to the local network, but no internet access. I can’t set a static address in the router, but can on the iPad, but no difference. I’ll have to contact either Apple or my ISP (Verizon Home LTE)

Try downloading and enabling the free version of Cloudflares‎ Faster Internet on the App Store This app resets all your network settings and sets up a new connection. I use it to solve a problem I have with access to a website I have.

Just a thought. Have you taken your iPad somewhere outside your home with WiFi? If it worked there at least you’d know the problem was in your setup, and if it didn’t, the problem is likely in the iPad.

1 Like

Hi, thanks for the suggestion. I downloaded and tried; the connection timed out. When I set the iPad to connect using my hotspot, Cloudflare connected. So unless there’s a setting in Cloudfare…

Thanks, Jack. No I haven’t tried that. Spent a long time on the phone with Verizon ISP, they don’t see anything on their end. Since it connects with a hotspot, I suspect it may connect on another network-I will try that and report back. If it doesn’t, ball goes back to Apple; if it does, to Verizon, I suppose. May be time to just buy a “modern” iPad…

No it should have worked as is out of the box.

I also have an iPad mini 2 that is still running iOS 12.4.9 because there were so many reports of wifi (and other) issues when the the 12.5.1 update came out. Now that 12.5.3 has been released, I’m seeing similar reports about problems with this update as well. Personally, I intend to stick with 12.4.9 rather than risk the kind of problem you are having. Unlike Macs, which can always be erased and restored to an earlier version of MacOS, Apple makes it almost impossible to go back once you install an update. This is very frustrating when flawed updates are released, as seems to be the case with 12.5.3 (and 12.5.1 before it). It sounds to me like neither your iPad not your settings are causing your connection problem. It’s probably the update.

@omalansky you may be right. I will pursue this a bit further, as I haven’t tried to connect to someone else’s wifi. But it may be a fool’s errand trying to prolong the lifespan of a Mini 2. Currently I see I can buy an 8th Generation iPad for $329 and Apple will accept a trade-in on my Mini 2 for $85, so $244 net. Or a new Mini 5 for $314. Apparently Apple wants me to upgrade :wink:

Yes, the iPad Mini 2 is old and slow. A new Mini (or any other recent iPad model) will give you a quantum leap in performance. Still, it’s very frustrating when Apple breaks older devices with faulty updates and leaves customers hanging.

Well, in this case, may not be Apple. I just took it to my local Kroger and was able to get internet on their guest WiFi network. So back to questioning Verizon…

Long past time to be at your ISP or Apple for assistance… nrk

Hopefully, this is good news for your iPad. Good luck!

@nrkmann both had been contacted previously and were unable to provide a solution. At this point it appears it’s the Verizon router, though as it was working prior on 12.5.2 (and still is on this iPad Mini 2 I’m using now) but stopped working after 12.5.3 update, it could be a combination of both the update and the router.

An old trick to get rid of mysterious network problems is to turn off all devices on your network. Then start them up again. Start them up again one by one with the connection to Internet first, your iPad last. I do not know your configuration, but in my case I would start the box that my router is connected to first, then the router. Then my switches. Then my stationary macs. I would check that those were on the internet, then I would start the problematic iPad.

Is your router assigning the same IP address to your iPad and another one of your devices? Mine kept doing that and I was having similar issues. I had to either reboot the router or sometimes just look at the list of connected devices for matching numbers and kick one of the duplicates off. Later some firmware update to the router seemed to fix it as it stopped doing that.