iOS14 bug with Do Not Disturb toggle

On my 12 mini (with the latest iOS 14 updates) I frequently use the Control Center toggle to turn on DND when I go to bed. Most times I choose the option ‘Until tomorrow morning’. I’ve noticed with iOS 14 though that often the toggle will switch to on, but DND will not actually activate (no moon icon in the status bar). To fix it, I’ll have to turn the toggle off, exit Control Center, and then start again from scratch. Sometimes I’ll have to repeat that two or three times until I finally get DND to actually engage.

Has anybody else seen this? Any way to fix this behavior? The workaround of course would be to manually engage DND via Settings or to run it on a fixed schedule. The former I don’t want to do because I know I’ll end up forgetting to turn it off again in the morning, while the latter doesn’t work really well for me because my schedule changes from day to day depending on what’s going on at work.

If anybody has a trick to get around this bug (yes, I submitted it), I’d really appreciate hearing about it. :slight_smile:

How about scheduling a known minimal block (e.g. midnight to 6:30am) where the time it starts is the latest anyone normally calls and the time it ends is before anyone calls the next day. If there are a few numbers that can interrupt at any time, you could set up a group of contacts that are allowed to override DND. For example, I have set up my immediate family, other tenants of my building, the building manager, and the local emergency notification number as a ‘Ring Thru’ group in Contacts.

Do you set an alarm on your iPhone to wake up in the morning? If so, and you are using the stock Clock app, you can make a Shortcut to turn Do Not Disturb off “When Alarm Is Stopped”.

I use a scheduled DND myself, but after reading your post last night, I verified that I am seeing the same thing, but only for the selection “until tomorrow morning” (which changes to “until this evening” during the day). The selections “For 1 hour” and “Until I leave this location” are working fine for me.

There is a 14.4 update coming today, so hopefully this fixes it for you. If not, perhaps you can just turn on DND and train yourself to turn it off as soon as you wake up in the morning?

Thanks, @ddmiller for confirming. At least it’s not just me. :wink:

I’m also keeping my fingers crossed for the 14.4 update. This bug isn’t mentioned in the release notes, but that doesn’t mean a fix won’t be included. :crossed_fingers: :slight_smile:

I don’t know if it was because of 14.4 or because of just restarting the phone, but this is now working properly for me.

Instead of setting DND, set Bedtime which does the same thing, keeps your screen dark, and automatically turns off when it detects that you’re up and using your phone.

And whenever something is funky on the iPhone, always do a restart.

Restart did not fix it for me so I’m keeping my fingers crossed 14.4 will take care of it. Planning on installing over the weekend if I don’t hear of any issues with it by then.

No luck. Installed 14.4 update around lunch. This evening tried it. Needed to deselect DND toggle and then try a second time for it to actually activate. :frowning: