iMessages Failing Me!

Seems I am back at it with Messages weirdness. Here goes:

Of ALL times this is NOT where I have to fight with their fruit’s software (going to be in the hospital with no visitors allowed for about a week), I need it to “just work.” So I communicate a LOT in Messages, I have a ton of “conversations” that I have with various individuals and a bunch if group ones. Got a cMP, iPad and an ifone. Always use iCloud. This morning I have a few words with a friend of mine… on my tablet. Boot up the cMP, make the coffee, blah, blah. Want to send another thought to the person, so I fire up the app on the desktop… HOLY SHIT. ALL of my many “conversations” are totally gone, BUT I do have the snippet I did this morning. BUT that was a very long standing “conversation” going back literally years. I’m freaking out…

Check my tablet and phone (iOS up to date on both, 13.5). BOTH places DO have all my stuff. Time to geek-test. I send something to that person from the desktop… it shows up on both the fone & tablet. Interesting. Sign out of icloud, then re-sign back in. Still no “conversations.”. Reboot the machine, nada. Now 6 hours later, the desktop is still devoid of any conversations. Anything I add in this “piece” of conversation on any device shows on all devices.

Now I have 2 factor with the fruit. Signing out then back in makes it such that when I tried to sign into my account via a browser, it sent a code to input for verification (says I was using a “new” device). AND it keeping with sloppy software, the code pops up on my desktop, where I had been trying to sign into my account! So doing the icloud log out then log in seems to have caught server attention.

It gets weirder. If I do a search, it finds the keyword way back in this “thread” like from 3/20 (but all I see it what started at 9:35AM today). BUT what I see on the desktop starts at 9:35AM this morning. BUT I can’t search on any of my other “conversations” it says “conversation not selected.”

Does ANYONE have a clue what is going on here?

I don’t know what is going on. (I don’t use iMessage on macos, only on iOS and iPad.)
However, I saw in the commentary on the update to iOS and iPadOS 13.5 that there is a similar update expected for macos any day now. Perhaps the iMessage app has gotten out of sync between the iOS and macos releases? If that is it, nothing to do but wait and see…
Oh, should things get out of sync? No, that’s a bug. If that is the case, I hope it gets fixed!
Take care of yourself!

I am kinda stuck in the Sierra/High Sierra era as I have a pretty good GPU (GTX 980) that does great running the MMO I like under Metal. Like I said, both iOS devices are up to the minute. Nothing at all changed in my system from yesterday to today, BUT I am thinking of some cache cleaning because that is the only think that I THINK might be a factor… Onyx, right?

Anyone know WHICH set of caches are most likely?

To be clear, I don’t think you need to update to Catalina. I meant that the next security update for High Sierra might include whatever needs to be updated for iMessage on macos to cooperate with iOS 13.5.
Or it might not. :no_mouth: We’ll see.
I hope your cache cleaning works and makes the issue go away.
Take care!

Where did you sign out of iCloud? If you only signed out on a single device that may well not achieve success. What I would try is to sign out of Messages in all devices. Reboot all devices and then sign back in to Messages on all devices.

On your iPhone check:

Settings -> Messages -> ensure “Text Message Forwarding” is checked

then on your MacBook select:

Messages -> Preferences -> iMessage -> Settings

Ensure “Enable Messages in iCloud” is checked and then click the “Sync Now” button.

I understand you said you waited 6 hours previously but without knowing what you actually signed out of that may not have been a useful wait.

Hope this helps and sincerely hope you are ok for whatever requires a week in the hospital.

I have had similar issues when migrating to a new computer. As I recall, the answer was NOT in playing with iCloud. Within the Settings list is a specific Messages item. Open it and toggle the iMessages switch off on your mobile devices. Restart and then toggle it back on. It may help. Note that I am not sure that the restart is actually needed, but it can’t hurt.

Thanks for the suggestions… must say I am reluctant to sign out of iCloud on all three devices at once, somehow I am concerned I’ll end up really losing everything.

I only signed out and back on on my desktop (cMP, not MacBook). I HAD gone looking for anything that would allow me to re-sync, but I have no such setting as mentioned. Yeah, I am pretty new to the iPhone, but yes I DID set text forwarding!

New kind of development today. On another long standing “conversation,” I got a new message on my desktop. PLUS I got a SMS text from my hospital… showing up on my desktop. I THINK this all means that my desktop client is simply NOT seeing ANY of the previous conversations that seem to exist in iCloud. Yes, the desktop has been off all night, freshly booted today.

I missed any suggestion to sign out of iCloud on all devices but I did suggest signing out of Messages on all your devices and then signing back in on each device. It could be quite a wait for messages to sync. I had an occasion where I left my iPhone alone overnight and in the morning it had synced everything correctly.

I have 4 devices.

  1. I use daily: iPhone and MBP

Then I have an iPad, used often but not daily

And an iMac that I use for music but not much else.

I have found that messages on the iPad are not always as complete as the first two devices. And the iMac has even less. I can respond to messages on the iMac and receive new ones, but the old ones don’t sync up. I’ve never bothered to sign in and out since they are still on the other devices.

Diane