HP Printer not seen - disabling IPv6 solved this

My printer is usually idle for days - and when I do need it, I often get a ‘printer not responding’ message.

This is with (currently) macOS v13.5 on an M1 Max MacBook Pro.

As a work around, I can print via IP printing - but lose the double sided printing option that’s available with the normally added printer.

Turning the printer Off, then back ON always resolves the problem.
But only temporarily - with inactivity, the printer again becomes unavailable.

Since printing is rarely needed, I was living with this.

However, recently I discovered that turning IPv6 off via the HP printer’s touch screen display has resolved the problem - at least, I’ve gone 5 whole days with the printer idle but available.

Posting this in case others, like me, were just living with the same problem.

1 Like

Hmmmm… I have a similar problem on an old Linux PC (running Debian 10).

This PC, when configured to use IPv6 seems to generate a new dynamic address every few days. This by itself isn’t a problem - IPv6 is supposed to allow that - but the old addresses accumulate in its configuration.

This PC is running Avahi - basically an open source version of Apple’s Bonjour - to advertise its name and addresses to the network. It seems that Avahi doesn’t keep up as the IPv6 addresses change, so other devices on the network that rely on it (like my Windows PC, which insists on using Comcast’s IPv6 DNS address instead of the IPv4 DNS address I configured for use on my LAN) end up with the wrong address and can’t connect.

I found that manually restarting Avahi temporarily fixes the problem, but I can’t take the time to restart it every day. So I chose the other option - disable IPv6, making the computer only accessible via IPv4, and my statically-assigned address. Since the address no longer changes, Avahi is always advertising the correct address, and everything keeps on working. This means the computer can only use IPv6 link-local addresses (which can’t reach the Internet), but v4 still works great and I don’t do much web surfing on that computer anyway.

It sounds like your printer is suffering from the same problem. For all I know, it might even be the same software packages.

A “proper” fix would be to manually assign a static IPv6 address so it doesn’t change, but that doesn’t work because I’ve got a dynamic address block from Comcast and my devices need to change when their address block changes.