HomePod Software 15.1.1 Prevents Podcasts Problems

Originally published at: HomePod Software 15.1.1 Prevents Podcasts Problems - TidBITS

Getting an error when you try to play podcasts on your HomePod running HomePod Software 15.1? It’s not you, it’s a bug, and Apple has just released HomePod Software 15.1.1 to resolve it.


After the update my Apple TV 4K did not recognise the stereo Homepods. Fortunately it was fixed by restarting all devices (all are on 15.1.1).

I set up a friends ATV and Homepod Mini and updated them to 15.1.1. All seemed to work well, with the HM as default audio output until I tried to Airplay from my iPhone to the ATV. No sound.
Bizarrely the HM came to life if I used the AppleTV+ app on the iPhone & screen shared to the ATV. I read elsewhere that the 15 update caused Airplay problems so it looks like 15.1.1 has not fixed it. Frustrating!

The last time I had to do my HomePod stereo restart it made one of the HomePods into a brick.
Apple support checked out the speaker and told me I need to big a new one. It’s not their problem.
I ended up buying a second hand one and setup a new stereo link.
Everything worked okay until the 15.1.1 patch was installed.
The 15.1.1 HomePod patch broke the built in ambient sounds.