Help Accessing WD MyCloud Home External Drive That Is Offline

Reaching out to this community to hopefully get some help with an issue with an external WD MyCloud Networked External HD. If this is not the type of post for this forum, I’ll gladly remove it.

I have a Western Digital (WD) My Cloud Home ( which is a network attached external hard drive. The way the MyCloud Home devices work is that you create a UN/PW and that is used to access the files via their local web ( interface as well as via MacOS.

I was trying to access the files on it yesterday via MacOS Finder and the password would not take.

Via the MyCloud browser based interface, the drive is saying that it is ‘offline’ and as such, that seems to be the reason I can not access the files. I have the drive connected to power and hardwired connected to my Wifi router via Ethernet cable. I am hoping/praying that the files are still accessible and able to be removed from the drive.

The LED on the front of the casing is ‘pulsing’ White. The LED on the back near the Ethernet port is green/occasionally flashing green.

In the MacOS Finder interface, there are two “partitions” of the drive, the one that I named ‘sgclark’ which held my manually backed up files and another named ‘MyCloud-XXXXXX’ (where the X’s are the device’s serial number) and in this latter partition, it holds my TimeMachine backups.

I can still see the TimeMachine back up files via MacOS Finder, so this is giving me hope that the integrity of the drive is still intact and the issue has to do with something that is preventing the drive from getting online.

Does anyone have any experience with this sort of stuff and may have some tips or tricks for me to utilize.

  • Is there a way via MacOS Terminal to access the drive and move the files to my Mac HD?
  • Is there a way to connect the drive via Ethernet or USB (it also has a USB port on the back) to access the files?
  • Are there any other ‘hacks’ or ‘technical’ methods to access the files?
    Right now, all I want is to be able to get to the files that are on the drive and hopefully move them off of this drive.

I’m still talking to Western Digital support however they have not been terribly helpful.

And after this, I’m going to go get a dual drive NAS and maybe subscribe to Backblaze! :slight_smile:

I recall when I had one of those for a while. I never ended up committing many files to it, but I did try it out.

You don’t mention whether you tried Disk Utility. I know that in recent MacOS releases it seems to have been progressively crippled, but it would be worth a shot if simply to see whether your Mac “sees” the drive. If the drive is visible in Disk Utility, try using the “Mount Disk” command to see if that is possible.

And if it is, scoot your files off it during the magic window that opens.

I’m also wondering if your Time Machine backup reached capacity, and if so, did it try to expand its partition? I’m not using Time Machine currently, but I recall it would really like to be the sole occupant of a device.

There is much more to this than I know, but those are the places I’d start.

That and a genuine NAS drive. I’m really happy with the one I have from OWC.

Good suggestion re Disk Utility. Unfortunately, it does not seem to be ‘seeing’ my external WD MyCloud Home drive. :frowning:

As for the partition, that seems to have been a configuration from the very beginning. Its as if there was the “Network/Files” part for normal files and storage, and then another area for the Time Machine back ups. It never really made sense to me.

I’m definitely going to aquire a genuine NAS drive after this experience (which is still not done). I spoke with WD today and they did give me some hope that all is not lost but it will be a few days before I get back in touch with them as they have ‘escalated’ my ticket. We’ll see.

Thanks for responding and for your thoughtful suggestions!!

I’m not familiar with this particular device but I would definitely be trying it via USB, if for no other reason than to eliminate the network as the problem.

Stephen…while there’s nothing wrong with a NAS…it is essentially another computer you’ll need to manage…easily done via the web interface…but it’s essentially the same as a conventional RAID hooked up to your computer…and if the computer is always on then a local drive will be faster performing and file sharing will provide the same accessibility to other computers in your house as a NAS will and the RAID is probably cheaper. Both the NAS and the RAID box made multiple drives and use the same RAID technology to make multiple drives seem to be a single volume and provide striping or redundancy depending on which RAID level is used…the difference is that the NAS has its own CPU, RAM, and management software that does essentially what file sharing will do for you. The NAS software may also provide additional features…Plex stream source or backup to the NAS vendor’s cloud but those capabilities can be easily provided by the host macOS computer as well. Some of the NAS products have 10 GB Ethernet add on capability but you’ll need a 10GB Ethernet switch and a Mac that has it as well. I looked at this a couple years back and ended up with an OWC ThunderBay Mini because it uses laptop drives and makes less (actually just about no) noise…it’s hooked up via TB to my Studio and to our laptops it’s appears as networked attached storage or a NAS. Just a thought if you want an easier to manage home solution.