Ghost of Big Sur 11.7.2

On Friday I attempted to apply the Big Sur 11.7.2 update to my iMac, which is booted from a Thunderbolt 3 SSD running 11.7.1. The drive is FileVault encrypted.

It immediately rebooted, but was stuck at the white Apple, with no progress bar. I gave it a good long time, but nothing at all happened. So I restarted it.

It came back to the Big Sur login prompt. I logged in, but after accepting the login, it hung on that screen.

After giving it a long time with no activity, I did an Option-boot. The boot drive was there but so was the Installer. I choose the boot drive.

After login, I got a macOS update progress indication on the login screen (as opposed to the normal black screen). After about 10 minutes it came up, but still at 11.7.1. Huh? It updated to the same version as before?

I wondered if maybe before when it hung at the login prompt, it was really trying to install 11.7.2 but with no progress bar. Today I did another option-boot, and guess what? The Installer is still there as a boot option.

I picked it, and just like before, I got the login prompt, after which it hung. This time I gave it 2 hours before rebooting.

So I’m still at 11.7.1, there still is a macOS Install to boot from, and 11.7.2 is gone from Software Update.

Any idea what’s going on?

Signed, Not a Fan of Big Sur

Has the release of 11.7.3 yesterday changed anything?

Haven’t tried 11.7.3 yet, but I did try 11.7.2 again on Friday. Same result as before. Once is a fluke, twice is a trend.

Tried 11.7.3 with the same result: it hung at the white Apple on the first reboot.

I suspect that the updater doesn’t like that I’m booted from the Thunderbolt drive. Which is weird, since obviously I can boot from that drive.

I do have a dim recollection that there can be issues with updating versions of macOS installed on external drives, but I can’t remember the details.