Forvo stopped working in Safari?

With Safari 16.4 in Ventura 13.3.1, suddenly pronunciations in seem to have stopped working for me, although they are fine in Firefox and Chrome.

Anyone else seeing this?

Thank you,


Just checked and yes, I have the same problem.

Thanks for confirming, @tmg2021.

I sent a message to Forvo and will post if I hear anything back.

Working again for me.


Thanks for he update, although unfortunately it still isn’t working for me, and I haven’t heard anything back from Forvo about it.

FWIW - I’m on a MacBook Pro M1 Pro, OS Ventura 13.3.1 (22E261), Safari 16.4 (18615.


I’m running the same system and Safari version but on an older MBP (16-inch 2019).


In Safari > Settings > Privacy settings, I have all the boxes checked except Cookies and website data: Block all cookies.

Are yours different?

I have
checked: “Prevent cross-site …”, “Hide IP …”

unchecked: “Block all cookies”, “Allow websites to check …” and “Allow privacy-preserving …”

1 Like

PS. I use Forvo for Irish pronunciation and it’s working for both suggested words “Sláinte” and look-ups “maith”.
I have an account with Forvo, but this is without logging in.


Thanks for the tips and additional info but still no dice.