Force iCloud Photo Sharing to sync in “Photos”?


(Jolin Warren) #1

I’m still clinging on to Aperture, as it has photo management/organisational features I can’t find elsewhere, and it’s still working for me. But that’s another discussion! However, it’s become too cumbersome to use for iCloud Photo Sharing (née PhotoStream), so the other week I decided to disable iCloud Photo Sharing in Aperture, create a blank library in Photos, and enable iCloud Photo Sharing in Photos. Doing this looked like it was working: all my shared photo streams appeared in the “Shared” section of the Photos sidebar. And most of them downloaded previous photos.

However, some of the photo streams have not downloaded any past photos, and are currently empty. A couple of these have now had new photos posted to them, and the new photos appear, but the previous photos have still not been downloaded. My oldest (and most prolific) photo stream, going back 6 years downloaded all past photos except for the very first one.

As I said, I turned this on a couple of weeks ago. I left it overnight, have used the computer and had Photos open regularly since then, but the streams that didn’t download past photos originally still haven’t. Is there some way I can force a re-sync of the iCloud Photo Sharing streams? Should I turn it off and on again? Any other tricks I’m missing (ctrl-clicking on them in the sidebar has not turned up anything useful)? Many thanks!


(Adam Engst) #2

Grasping at straws here, but what happens if you look on the iCloud Web site?


(Jolin Warren) #3

That was a good thought, I’d never considered that I could get to Photos on iCloud. Unfortunately, it doesn’t seem to show shared albums. :slightly_frowning_face:


(Adam Engst) #4

Ach, sorry. I fear that this may be one of those situations where the only real solution is to stop using the unsupported software. :frowning:


(Jolin Warren) #5

Ah, maybe I was unclear. This all worked fine in Aperture. It’s because I’m trying to stop using it that I’m having problems. :confounded: I’ve turned off iCloud Photo Sharing in Aperture, but can’t get Photos to properly load them. Maybe I’ll try turning it off and on again in Photos and hope for better luck.


(Jolin Warren) #6

Wouldn’t you know it, but after posting my last comment, I opened Photos to turn iCloud Photo Sharing off and on again, and lo and behold, all the shared photo streams are there and have all the photos loaded!! I have checked it over a couple of weeks and not had any luck until today. Maybe logging into the iCloud website and looking at Photos there somehow knocked it back into shape, even though the shared streams don’t show there. I also freed up some space on my internal drive yesterday, so alternatively maybe that was it (though I’ve had this level of free space since having the problem)? Who knows, but thanks Adam!