Fixing conflict between Ventura 13.0 & Luminar AI

Luminar AI is my favorite photo editing app, but it stopped working on my iMac after I updated the OS to Ventura 13.0. It just crashed on launch.

A little research led me to their support app, which provided the following solutions. The second one worked for me.

Let’s try restoring from backup:

  1. Hold down the Option key on your keyboard and start Luminar. Keep holding Option until you see a window with a list of available backups appear.
  2. Select a backup that has been created prior to when you encountered the issue with the library and click Restore from Backup.

When that didn’t help:

Please, try this instead:

  1. Make sure Luminarᴬᴵ is closed.
  2. Locate your Luminar AI Catalog folder. The default location is %username%\Pictures. If you specified a custom location, search your custom location.
  3. Rename Luminar AI Catalog folder as well as the Luminar AI Catalog.luminarai file inside this folder.

[In my case “Luminar” was spelled “Lminar.” I inserted the missing “U”.]

  1. Open Finder.

  2. Navigate to Applications > Utilities > launch Terminal.

  3. Paste the following string into the Terminal window: defaults delete com.skylum.luminarai

  4. Press Enter on your keyboard and close Terminal.

  5. Launch Luminarᴬᴵ. Go through the initial setup. Leave the location of the catalog at the default (in the Pictures folder). Here’s a video tutorial that can guide you: Loom | Free Screen & Video Recording Software | Loom

This worked for me.

1 Like