Extracting Data from an Old iOS App Broken by iOS 14.5

Well, it wasn’t like I hadn’t been warned, and I wasn’t that attached to the data. But once I started down the path of trying to recover, I got interested…

The one thing I might have asked the developers for was the SQL incantation to create a proper backup from the database that I had extracted that I could then import into the new version. That seemingly should have worked.

Adam, many thanks for this extensively documented article. Really valuable!

It also exemplifies the way to success in IT matters: never give up! :slight_smile:


I also liked Momento until they got too fancy, but I exported the data way back when. One of the features I liked was the good export into html.

A trick that worked with a few old apps that wouldn’t launch after the 14.0 upgrade is to off-load the app leaving the data on the device, then download the app again. I don’t know why this worked the times it did, but I suspect that it may have have been that apple updated the certificate at some point like they just did with a whole slew of oldies.

I enjoyed learning everything for the article, but it turns out I might not have had to do nearly as much gruntwork.

Thanks to Aidan Fitzpatrick of Reincubate for telling me that not only does their iPhone Backup Extractor utility have a way to modify a backup such that you can change data and restore it to an iPhone, they’ve written instructions explicitly for Momento.

It turns out my hunch about backups having checksums was correct, but apparently, iPhone Backup Extractor can update those checksums to match the new data. I’ll give it a try soon.

Their support team has written a bunch of similar how-to guides that are well worth checking out if you’re having issues.

1 Like

This is probably a silly question, but did you try the iTunes export feature? Or has that vanished with iTunes itself?

You can still access files on the iPhone, even without iTunes, but that works only for files that are explicitly made available by apps, not the app’s internal files.

In this case, if I had been able to launch Momento Classic and create a backup or export, that file would have been available in the Finder to download and transfer. But of course, if I’d been able to launch Momento Classic, I wouldn’t have had to jump through any of these hoops! :slight_smile:

1 Like

I had a slightly different issue, when I updated my iPhone 7 to iOS 14.5.1, the app Grocery IQ would not launch, iOS said it needed to be updated. When my wife upgraded her iPhone 12 to iOS 14.5.1 a few days later, Grocery IQ worked.

I offloaded the app on my phone and then reloaded it, and the app now works on my phone. My only guess is that there was some filesystem corruption in the app during the upgrade. Redownloading it by offloading and reinstalling fixed that.

1 Like

Hey @Steve_Nicolai, thanks for this detail! I hadn’t considered the possibility that the app had somehow become corrupted, in part because the dialog is so matter of fact about how the developer needs to update it and in part because several other apps were affected.

However, you were spot on—when I deleted the Momento Classic app and reinstalled it, it opened up fine. This alone wouldn’t quite have solved my problem because deleting the app also deleted its data, and when I reinstalled it, its data was gone. But now I believe I could have restored the data through iPhone Backup Extractor.

I confirmed your technique by deleting and reinstalling Photo Studio, another app that was showing the same problem. Complete success, though if the app had any data (I never really used it, so I don’t know), it would have been lost too.

What this suggests, however, and I can test this later, is that erasing the iPhone that’s having the problem and restoring from a backup might fix the problem purely from the standpoint of reloading the app from the App Store during restore. I’ve found another app on my iPhone 11 Pro that’s showing the problem (NME Daily), so once I have the time later today, I’ll backup, erase, and restore. I think this will work in part because all the apps I’ve had trouble with in this way work on my iPhone 7, which was restored from the iPhone 11 Pro backup.

I do believe this will be contingent on the app still being in the App Store in some way. I don’t quite know what drives this, but some ancient apps are, whereas others are not.

Notice that I said offload, not delete. Offloading removes the application without deleting the data for the application. You can then reinstall the app and keep the data. Offloading is done through Settings → General → (iPhone or iPad) Storage.

Right—offloading is different from deleting! The only hard part is that it’s hard to find apps in Settings > General > iPhone/iPad Storage because they’re listed by size, not name. Lots and lots of scrolling, later, I’ve now gotten a chance to test this with a handful of apps that were showing the problem. There are two possibilities:

  • Offloading and reloading the app, if successful, renders it functional again, presumably with its data, though none of the test apps I had seemed to have had data.

  • With some apps, when you try to reload the app, you get an error that it’s not in the App Store anymore, and all you can do is delete it. In this case, you’re not really any worse off (and I suspect those apps weren’t really functional before iOS 14.5 either).

I suspect, but I’m not going to bother to test now, that a backup, erase, and restore cycle on the iPhone would have the same effect. But it’s probably not worth it for the one or two apps someone might have in this situation.

Note that there is a Search function so that you can narrow the possibilities easily.

1 Like

Doh! I actually pulled down a couple of times because search fields are often hidden that way, and I never even saw the magnifying glass icon. :slight_smile:

Adam, the title of TidBITS #1565 is a little misleading because it says “… fix apps broken by iOS 14.5”.

I was hoping it would tell me how to fix an app made by the late Hardy Macia so I could use it under iOS 14.5. Because 14.5 & later kills this app (crucial to me and many others) I can’t go past 14.4.2. Unfortunately, there isn’t a newer version so the that is out and my backup iPhone is an iPhone 6 that is limited to iOS 12.x.

This gave me hope that I might be able to extract several years data from Migraine Diary (Apple now say I cannot use this in UK) backup in iMazing. Any suggestions of how to proceed? I’m not good with databases.

Did you read what I said about offloading and reloading the app? If it’s still available in the App Store, that should bring it back to life in iOS 14.5. But you’d need a device to test this on, since if it’s not available, offloading it kills it.

The iPhone Backup Extractor support people seem to be aware of this general concern and may be able to help. iMazing support may as well. Beyond that, you need to find someone who could help walk you through using one of those apps and seeing what the exported data looks like—there’s no guarantee it’s in an SQLite database format like mine was.

Yep, but unfortunately that won’t work for me. After Hardy passed away, the app was bought by an Italian guy in Europe. He promised to update the app so it would work on new iOS versions but he lied. What he actually did was convince another European developer of a similar app already in the App Store to license that app. The Italian then rebranded the licensed app as a new version of Hardy’s original app and it is that “new” app that is on the store. So now there are two identical apps on the store but with different name and “different” developers. The licensed app isn’t as good as Hardy’s app by a long shot.

I’m not sure if I’m quite understanding, but if Hardy’s original app remains available for download to previous purchasers (questionable given that he passed away), the offload/reload could still work. You could test this, if you had a test iPhone, by erasing it and restoring from the backup of your main iPhone. I can’t think of any easier way to test without potentially losing the app in the process.

It sounds like the people who took it over afterward reused the name for an entirely new app (at which point it would have a different ID at the end of the URL, like id980592846). If that’s the case (much as Momento replaced Momento Classic but was a completely different app), it wouldn’t take over from Hardy’s original app in the offload/reload cycle.

Yes, that is what SHOULD have happened but others who had Hardy’s version and just let it update found the cloned substandard app. AFAIK, Hardy’s version is totally gone, only the name remains. I’ll check with some of the other users and ask if anyone tried the offload route.

I was able to use iMazing to backup my iPhone before updating. My simple milage app failed to work after the update to 14.5. Fortunately I have an iPhone 6S that is still on an older operating system. I restored ONLY the failed app to the 6S using iMazing and all is there working perfectly with the latest data. I was not able to update the app as it has not been in the app store for years.

Oh, interesting. So you were able to back up an app on one iPhone and then restore it to another even though it was no longer in the App Store. That’s good to know!