External drive permissions problem

When my venerable ‘08 17” MBP finally slowed to a crawl, I sprang for an iMac (High Sierra). Both SSD internal drives from the MBP went into enclosures. One had been used strictly for files, no operating system, so I kept it as is, keeping its name and contents unchanged. But now almost every time I want to add, change or delete a file on that drive, i have to authorize it. I have tried changing its permissions from “fetching…” to me in the get info window, but that sticks only temporarily. I use SuperDuper to back it up 2-3 times per week and wonder if that process could be causing the problem. Suggestions?

@tinagarf

If it will let you do it I would select “Ignore ownership on this volume” at the bottom of the Get Info Permissions window. For the most part when external drives are just used for storage the drive(s) don’t require Permissions enabled the same way as a boot drive.

That’s the problem. I have to keep telling it to ignore permissions, but it doesn’t stick.

You said you were trying to change the permissions from “fetching…” which is a different aspect than what I suggested. So just to clarify, the option to “Ignore ownership…” is separate from the permission section and is that what you tried to change and the setting does not hold?

When I check the box to ignore ownership, the permissions change from “fetching…” to “me”. But that change does not last, even when locked. I am going to experiment to see if the problem arises after SuperDuper cloning. My hunch is that the drive permissions may have been set by MBP which originally formatted the drive way way back under some older OS. Worst case, I will erase and reformat the drive, then copy (not clone) the files over to it from the backup clone. I was just wishfully hoping there might be a quicker fix.

Hmmm, frustrating I’m sure. I wish I had the silver bullet

After you ticked the “Ignore ownership…” box did you try clicking the action menu button and selecting “Apply to enclosed items?” I will guess you did try that.

Have you run Disk Utility First Aid on the drive?

I would contact the SuperDuper developer. If your hunch is correct perhaps he has the solution for you.

Problem solved, I think. Apparently, since the drive was initially formatted internally on the old MBP, it was still identified by Disk Utility as an internal drive with associated permissions and ownership. I mounted the disk on my MB Air, erased, renamed, reformatted, reattached to iMac, copied files over from backup, and all seems to be fine. I think when I set up the iMac I used Migration Assistant for some of the setup, and permissions/ownership for that drive was copied over and took control of the drive. So it wasn’t a SuperDuper problem. I may have gotten away with simply renaming the drive, but took the belt-and-suspenders route of totally cleaning and reformatting it. Thanks for all the help, as always.

Whoa Nelly! Another development. The SSD mounts as external drive when attached directly to one of the iMac’s USB ports. If I attach it to my external OWC Thunderbolt dock, it mounts as an internal drive. I have three other external drives attached to that same dock, also via USB, individually, not daisy-chained, and they all mount correctly as externals. They all are regular drives, not SSD. I can live with this, but am fascinated. What gives?