External disk spontaneously dismounting

I’ve experienced this infrequently (maybe three times in the last six months, but two of those were in the last month), running Mojave. Sleep was not an issue; I was at the Mac and doing stuff. My latest guess is that it was a faulty USB hub, which I have taken out of service. I have not had any problems since removing the hub, but that in the past week.

USB hub is a good suspicion.

Also, I’d always be weary of voltage sag on AC mains. At the lab I work we monitor those closely and it’s surprising to see what kind of fluctuations occur and how frequently. If you can see the lights flicker, that’s likely more than 10% change in voltage over more than 50 ms. Depending on the enclosure’s transformer and DC circuitry that might be enough to interrupt.

1 Like

Thx Will. Another answer pointed me to an Apple Discussion thread,


that suggested resetting the SMC. I tried that (my iMacPro has a T2 chip, somewhat suspected of being behind this problem). I did that last night (easy… unplug, let sit for at least 15 seconds, plug back in wait 5 seconds before pressing “ON” button). So far no problems…



Would a UPS protect against this? I thought so, but something I read said it often doesn’t have a quick enough response.

Would the make and model of (consumer grade) UPS make a difference? My setup gets power through a Tripp Lite, but I would switch to an APC if that made a difference.

It will depend greatly on the specific model UPS you have. Some only transfer over when there’s a power outage. Others will dynamically boost/trim voltages in order to deal with changing line conditions. The sensitivity is often configurable as well.

I use an APC SmartUPS SMT1500 at home and it does all this, but this is not what I would consider inexpensive for consumer use.

Tripp Lite is a good quality manufacturer, but like everybody else (including APC), they have a wide variety of products. Some will not be suitable for you and others will be. And within those that are suitable, some will be affordable and some will be too expensive.

Unfortunately, this is an area where you really need to do your homework. Learn about the buzzwords and features and then start reading lots and lots of technical specification pages. Things that I consider very important:

  • True sine-wave output when on battery. Some models (especially inexpensive ones) have “stepped sine-wave” output, that really isn’t good for computer power supplies. And with some models, the quality of that stepped sine wave degrades as the load approaches the UPS’s maximum.
  • The ability to boost undervoltages and trim overvoltages
  • Surge and power filtering. Clean power, even when not on battery, is important if you want your equipment to have a long life.
  • Capacity. Calculate how much power your gear consumes. Make sure the UPS’s capacity is at least double that. The last thing you want is for the UPS to cut out in a blackout because it got overloaded.
    • But note that there is a limit. Once the capacity gets over about 1500VA, you will probably find that the device must be attached to a high-current circuit (20A or 30A is not unusual for UPSs in the 2000-3000VA range)
  • Run-time. This is distinct from capacity. Figure out how long you need/want your gear to run on battery before you are forced to shut down. Most good UPS manufacturers will provide a chart showing the run-time for a given load. Make sure the model you select can give you the run-time you need at your equipment’s load.
    • Some UPSs (generally more expensive models) give you the option to attach extra batteries. These will extend your run-time, but will not increase the capacity. When pricing a solution (especially for larger units) consider a lower-capacity unit with an extra battery pack vs. a higher-capacity unit.
  • Management. Most non-industrial UPSs these days have a USB port for connection to a computer. You may find some that still use a serial port for management, which is very inconvenient, because you’ll need a USB-serial adapter in order to do any management over that interface.
    • macOS can detect most major brand UPSs and let you perform basic management (e.g. automatically shut down the computer when the battery drops below some minimum capacity).
    • More advanced management may require third-party software. Some UPS manufacturers bundle this software with devices, while others charge for it. And it’s not always Mac compatible :frowning:
    • Although you probably won’t need it for home use, higher-end models allow management over Ethernet, or can provide an add-on card for Ethernet-based management. This can be nice if it is powering more than one computer, but is probably a waste of money for personal/home use.

I have just trashed an OWC Mercury Elite enclosure that did the same thing – spontaneously dismounted with the “Disk not ejected properly” message. The enclosure had three different interface ports and only dismounted when the FireWire one was used. It held a backup disc for my large music collection, was only used for backups, and dismounted durning backup operations, necessitating a run with DiskWarrior to catch any errors and on one occasion a complete scrub and recopy. The two USB3 ports worked fine. I changed my backup strategy to accommodate this and used the enclosure regularly that way, until last week the drive simply refused to mount at all. Repair efforts with DiskWarrior and Disk Utility failed. I removed the drive and put it in a (much less expensive) Orico USB-only enclosure from NewEgg. The drive is working fine in that.

David: Before finding out that Feedback Assistant, and your advice in general was really directed at beta versions of the OS, I carefully documented, per your suggestion, an “interesting” problem I have encountered, that may in the end be related to a fault in a basic chip design. It’s all I can think of. Is there a way of bringing this to the attention of Apple?

External disk spontaneously ejects… T2 chip problem?

This is a new problem that I have never encountered before. My most recent Mac, an iMac Pro was purchased 3/14/19. (3.2 GHz intel Xeon W, Mojave 10.14.6) I have not upgraded to Catalina (for reasons of legacy software), but have updated system versions as they were released. I have used an external disk for Time Machine backups. (OWC Mercury Elite Pro, using USB port on iMac, and USB 3.1 Gen 1 port on disk.) Backups worked flawlessly for almost a year.

As the disk was getting full, I purchased (on 2/20/20) another OWC Mercury Pro Elite disk and started a new Time Machine backup (using the same USB connection). After a few hundred gigs the backup stopped with a “Disk not ejected properly” message. I cycled the power on the disk, it remounted with no problems, but then ejected spontaneously after a few hundred gigs more. It finished the backup (about 1 TB) after another two or three power cycles on the disk. I left the system running for incremental backups, it would run about a day and then spontaneously eject. This pattern repeated itself thereafter.

I spent half an hour with a tech from OWC, who said they had seen this problem with Catalina, but never with Mojave. In the end he had no solution, but did offer to exchange the disk if I thought this necessary. (So far I have not taken him up on this.)

I posted a query on Tidbits Talk (“External disk spontaneously dismounting” Jose Alonso, June 10, 2020), and received several replies documenting the same “disk not properly ejected” messages, with different disks, different connections, and not related to Time Machine. However, the message that proved most useful pointed me to:


which led to:

this last intimated a possible problem with the T2 chip, suggesting that resetting the SMC might help. The procedure given was to power down the computer, unplug it, wait at least 15 seconds, plug it back in, wait about 5 seconds then power the computer back up.

Also note, my iMac is on all the time, it had not been rebooted in many weeks, probably not since the last power drop by PG&E in our area.

I followed the reset recipe, and had no “disk improperly ejected” messages for several weeks. Recently the messages started reappearing. I cycled the disk power, … the problem has recurred with a frequency of about once per day. This afternoon I repeated the power-down-SMC-reset process, it is probably too early to say but so far the problem has not reappeared.

As I say, I have never seen this problem before, so it must be related to either a subtle hardware problem, a modification (“update”?) of disk controllers spread across different disk vendors (it did not occur with the previous OWC drive), or some other new sensitivity.

I am a nuclear physicist, and have been involved with work at Berkeley Lab on radiation sensitivity of chips, specifically single-bit upsets (soft errors) caused by cosmic rays. Any chance this may be behind this problem?

I haven’t seen this problem before. It could be a hardware problem, or a software problem. Unfortunately, intermittent problems like this are very hard to debug.

Look in the Console log to see if there’s anything in it at the time disk is ejected that indicates what happened.

If it’s a hardware problem, you might try replacing components. Try a new hard disk, disk power adaptor, cable. You might try putting everything on a UPS in case a power surge is affecting it. If the computer is under warranty, you could take it in to Apple to have them look at it,

If it’s a software problem, you could reformat the disk and reinstall the OS and your apps. Don’t install any non-Apple code except for simple apps. If you use anything slightly dodgy, install them one at a time, and see if the problem returns.

The OS can’t eject disks with open files on them, you might try leaving a file open on that disk.

Unfortunately, this is slow, painstaking debugging. There’s no simple way to determine if it’s a hardware or software problem.

As @ace points out, reporting this to Apple as a bug is probably not going to do much for you, since you can’t provide any info that would help an Apple engineer reproduce the problem.

1 Like

Thx Adam. You’re right, this is the worst sort of problem to try to work through, if data points only accumulate on a weekly basis. However, if it’s weekly for me, but is a problem many people see then there is a stronger flow of data. I’ll spend more time going through the Apple discussion channel.

Thanks again for Tidbits! It’s been a constant companion of mine for many years.



1 Like

Thanks David. Don’t know exactly how Time Machine works, but if it ejects in the middle of a backup, aren’t there open files on the disk that got ejected?

You’re right this is a very difficult problem to debug, I was hoping to find that it was more common than I have encountered, so might already have some brainpower invested in tracking it down.

Best… Jose

There could be open files on the disk the got ejected. There could also be file system caches that haven’t been flushed. Either could cause you to lose data, or even corrupt the disk. That’s why the OS puts up an alert saying the disk was improperly ejected.

I’d take them up on this. I’ve seen a similar issue. Had a disk which was the first disk of a concatenated set used to backup 9 TB of data. Anywhere from 50 to 500 GB, the disk would spontaneously disconnect. Nothing in the SMART stats. Replaced the disk, the problem went away.

Thx for advice.



My problems with “disk ejected” started fairly recently on a 27" iMac I bought in January. I also just had a conversation with a friend who is also seeing this problem lately. I have three USB3 external drives - SSD, 2.5" bus powered HD, and 3.5" externally powered HD. All of these have been randomly ejected, usually overnight.

Multiple folks suggested this might be a power issue. So I bought a powered USB3 hub. This actually made things worse, in that it caused a kernel panic upon eject. The kernel panics all look the same, with a reference to Thunderbolt power. After experimenting with various configurations, this is what I found worked for me:

  1. Connect all external HDs and SSDs through a powered USB hub

  2. Connect that hub to a USB-A port on the Mac - and avoid using the USB-C/Thunderbolt3 ports completely

The above two changes seem to have stabilized things - neither one alone was sufficient.

My personal impression is that this bug was introduced with a recent update to Catalina, as my once stable configuration went seriously wrong and the random ejects affect multiple drive brands and types.

I’ve had a similar problem with the OWC TB2 drive dock (dual disk). I use one disk for a CCC nightly backup and the other slot for Time Machine.

I returned the first dock and OWC sent a replacement which also is exhibiting the same problem. This is with Mojave on a 27" 2017 iMac, so this isn’t exclusively a Catalina problem.

It got to the point where the disks wouldn’t mount. I repaired both disks with DiskWarrior and the problem became much less frequent, so I suspect there could be some kind of issue with directory corruption as a contributor.

Note: I was previously using two NewerTech FireWire drive docks in a similar application and would also get unwanted ejections, but those were rare compared to the dual TB2 dock.

Thanks for this info. My iMac Pro has a T2 chip, I gather, and when the unexpected dismounts occur with regularity (greater than once per day), going through the process of resetting the SMC seems to provide several weeks of stable operation. Interesting that your second disc didn’t fix the problem. Thanks too for the heads-up that there may be corrupted files on my disk. I’ll get DiskWarrior, even if it won’t look at the internal disk that is APFS formatted.

It isn’t that there were corrupted files, it was the directory that got progressively damaged and then corrupted enough to not mount. However, this would seem to be a chicken and egg problem: is the problem the unwanted ejections that create directory corruption (that builds over time) or was there pre-existing corruption that caused the ejections that then created more corruption?

I’ve had WAY fewer unwanted ejections since I rebuilt the directories on all of my backup disks (I alternate between two sets).

Thanks again. Message is clear though, whether chicken or egg, … FIX any corruptions, for sake of integrity of backups if nothing else.

Yes, and you definitely want to get DiskWarrior. Disk First Aid refused to repair the disk, but no problem for DiskWarrior. Be aware that DW will take a long time (like several hours for a 3TB disk) to rebuild a Time Machine directory due to the huge number of links.

For those who don’t know, Disk Warrior is not a universal disk repair tool. It only does one thing (rebuild the directory structure of HFS+ volumes), but it does that one thing better than anybody else and is therefore a critical tool to keep in your toolbox.

You will still want other tools (including Apple’s Disk Utility/fsck) for repairing other kinds of damage. Especially on APFS volumes, which can currently only be repaired by Apple’s tools.

And, of course, no amount of repair tools are a substitute for a good backup strategy because sometimes the damage is so bad that the only practical option is to erase the volume and restore the files from a backup.