Ethernet + WiFi on my iMac

I always have desktop Macs connected via Ethernet. I would like to use features like Airdrop and that requires a WiFi connection.

Long ago I would encounter problems if a Mac was connected via Ethernet and WiFi was turned on. Is this still likely to cause problems?

If you turn on both, how does software decide which path to follow?

I have not had any problems with having both on on my iMac. Make sure to go to System Pref -> Network and with the gear on the bottom select Set Service Order to put in the your preferred order.


thanks. I didn’t know about that setting

And if you ever use hotspot to an iPhone or iPad to give your Mac internet access you should check your Mac settings to make sure it has not put the hotspot at the top of the list. That can eat through your mobile data plan!
The irritating thing is that the Mac (or iOS device) can reenable a hotspot that has been turned off on the host device without the user of that device knowing (recent iOS updates might have fixed this)

1 Like

Instant Hotspot is a recent iOS feature, so there really isn’t anything to be fixed and I suspect it would be an uphill battle to convince Apple to remove it.

As the support article outlines, there are several items required in order to allow this feature to work. Computers/iDevices must meet continuity hardware requirements, be signed into the same AppleID account with both BlueTooth and WiFi turned on.

1 Like

Iin Network preferences / Advanced there is a check box as to whether or not to Automatically join the Hot Spot. Keep it unchecked and you shouldn’t be connected unless you manually choose the hot spot

Thanks, Ray Kloss. Didn’t know about that option.

Is that in Catalina? I’m in Mojave at the moment and don’t have that option.

I have one computer on Catalina and another on Mojave. The option appears on the WiFi panel in Catalina (no need to go to the Advanced option) but does not appear in Mojave at all.

I have it in Mojave (10.14.6).

In Network Preferences, highlight Wi-Fi in the left-hand panel and click the Advanced button in the lower right.

In the panel that appears, click the Wi-Fi tab, then under Preferred Networks, highlight your Hotspot device and click or unclick the box in the right-hand column (under Auto-Join).


Thank, yes, mine’s unchecked.

No I am running Mojave and it is in SysPref/Network/Advanced under the WiFi tab


Airdrop requires that both devices (e.g., iPad and Mac, or iPhone and iPad, or two iPhones…) have (a) Bluetooth turned on and (b) WiFi enabled. That’s all. You do NOT have to be connected to a WiFi network; Airdrop creates its own secure network – using those two technologies – between the two devices.
I have Airdropped photos and Notes to and from my iPhone and a new acquaintance’s iPhone on an airplane (in Airplane Mode!), in the middle of a desert, on a beach, and in a bus. It is a wonderful feature of iPhones, and it makes nearby Android users jealous (though few of them will admit it).