Emoji-picker doesn't respect tap-to-click

If you’re like me, you have your MacBook trackpad “tap to click” option set, so that when you tap the trackpad, that serves as the “click” gesture.

This works for everything I do except for one thing: selecting emoji. When I want to do that, I’m forced to actually click the trackpad.

To see what I mean, try this:

  1. Start typing something on a MacBook with tap-to-click enabled (Settings > Trackpad > Tap to Click)
  2. Press Control-Command-Spacebar to bring up the emoji picker
  3. Tap on your favorite emoji
  4. Result (for me): the emoji picker goes away, but no emoji has been inserted

But now repeat the above, but in step 3, do an actual trackpad click. Now, the emoji actually inserts.

Do you all observe the same behavior? It seems a lot like a bug to me. And quite annoying…


I tried it in an email reply to your message (in Mail.app under Big Sur), and it worked, but it appears that the list won’t accept emailed submissions containing emoji, since 45 minutes later, it’s still not visible.

But on the website here, it worked as you describe: Tap-to-click failed to insert the emoji, but a full-press click did. So I tried it multiple times in a few more apps that I happened to have open and on a couple of different web sites, and I found that it’s inconsistent everywhere: sometimes it inserts the emoji on a tap, and sometimes only on a full click. I have found no correlations with which emoji is chosen.

Now, that said, here’s an additional data point: I have had tap-to-click irregularities on my 2019 MBP 16" since I first got it, so I’m reluctant to call this specifically an Emoji Picker bug. Tap-to-click frequently will fail on a first attempt, and it varies inconsistently over time and between apps. I had the same problem on my previous MBP (a 2010 17"), but less often, so I suspect it’s related to multi-touch trackpad sensitivity.

You didn’t mention which MacBook you have or how old it is, or which version of macOS you’re running. So my experience may or may not have any underlying similarities to yours. But given that I’ve experienced intermittent tap-to-click issues on multi-touch trackpads pretty much since they were first introduced, I would pin the problem on either the hardware in Apple’s multi-touch trackpads or something in the driver, not the Emoji Picker specifically.

1 Like

Oddly enough, I’m noticing the same thing on an old MBA running Linux Mint 21.2. Maybe it’s a hardware thing?

Interesting! Well, it’s certainly software that maps the touch gesture to the “click” event, since it’s just a switch in the Settings area on the Mac. So it makes sense to me that if that mapping software doesn’t exist on Linux that all you will ever get out of a click gesture is a click event.

But that’s a good data point to compare to.

Okay, so I just tried it here on my iMac (3.4 GHz Quad-Core Intel Core i5) running macOS Ventura (13.3.1 (a) (22E772610a)) using a Trackpad, and it behaves exactly how I described in the OP (application, this comment field) >>> :sweat_smile:

And just went over to my MacBook Air M2 2022 running the latest Ventura, and the experience is identical. (Application: Notepad)

Can you give an example of where the tap to click DID insert the emoji? I’d like to try it here, since for me it has consistently failed.

I normally don’t use emojis, but in trying it on my MacSutdio running Ventura with a black Magic Trackpad, it appears to work.:grin:

It inserts the emoji with just a tap? No need to click?

Does that trackpad have its own driver installed with gesture settings?

It seems to work for me more often than not in Mail.app. I just tried it five times in a row, using the same emoji, and it worked on four of the five attempts. But it doesn’t work 100% of the time for me in any app.

Tbh, I don’t normally use the Emoji Picker from control-command-spacebar. Ninety percent of my emoji use is in Messages, and the Messages window has its own Emoji Picker button. Tap-to-click works consistently for me in Messages when using that Emoji Picker button. Interestingly, the control-command-spacebar Emoji Picker doesn’t seem to accept tap-to-click in Messages at all for me, though it does accept a full-press click.

1 Like