Downloading multiple images from a Mail message on the iPad?

Here’s a weird one and I can only imagine TidBits members figuring it out. Apple Support was beyond useless on this.

A member of my weekly volunteer group (hibikinokai.org) edits the newsletter each week. We stopped holding in-person meetings in 2020 and switched to Zoom. I grab a lot of screenshots and email them to her.

She says up until just a couple of weeks ago she could tap on one image in Mail on her iPad and see a menu pop up offering to let her download all of them at once.

This is in Japanese, but the items read:

  • Open in new window
  • Markup and reply
  • Save image
  • Save 32 images ← this is the important one
  • Save in Files
  • Share
  • Copy

But now it looks like this:

The only item that has gone missing is the “Save 32 images” option.

When I try a test like this on my iPad, if I long-touch an image then a short menu pops up with just a few choices, including Share. If I tap Share then one of my choices is save to Files. So it’s a two-step procedure with me and I don’t see an option to save all the images at once.

I chatting with Apple Support and they insist it can only be done one image at a time. But if I search on the web there is mixed messaging about that - even in the Apple support forums.

So… what’s going on? Anybody know?

Thanks.

I don’t know what happened to the your previous method, but if you mouse-over the address area you will get a pop-up w/ a paperclip attachment menu that allows saving all attached photos.

This is an iPad.

What version of iPadOS (you and your editor)?
What email client (you and your editor)?

Sorry, I missed that. On my 1st Gen iPad Pro (12.9"), I get a similar, but not identical menu. However, the menu item to save all the images is still there w/ iPad OS 15.7.

Maybe I’m misinterpreting your explanation of what to do. But I just tested again on my iPad Pro 11" 3rd generation with iPad OS 15.7 and i’m not seeing any menu item to save all the images.

In my new test mine worked as well. Not with hovering over or tapping the address, but in doing it like my friend, by long-touching one of the images.

And it’s working for her now as well.

So all I can conclude is there was something odd about the photos in whatever she was originally trying.

doug

1 Like

Sorry I wasn’t more detailed re: long-touching. Glad you worked it out.

It appears the problem was this:

  1. If I take a screenshot and paste into mail it’s ok.

  2. But if I copy an image from somewhere (the web, from a PowerPoint file) and paste it into the email it appears to disrupt that function.

doug

You’d have to look more closely at the mail message (I recommend using a good quality mail app on a computer, not your iPad).

It may be that some images are delivered as a part of the mail message (as attachments) while others are delivered only as links to image data stored elsewhere (e.g. on a web page or a file sharing server like DropBox or SharePoint).

iOS may only be supporting the bulk-save option for images embedded in the mail and not for “external” images that are links to network locations.

In the problematic email, some were images that were copy-pasted from PowerPoint and some were screenshots that were pasted directly into the email. For an ok one there were all screenshot that were pasted directly into the email.

doug