Did Ventura break folder aliases?

If I take regular folder and in Finder make an alias of it, that alias can be moved anywhere else on the partition and behaves just like you’d expect from a folder. So far so good. But if I drag that alias to a folder that happens to be sitting in my Dock (set to display as folder, not stack), it will show up in there with a generic document icon and a little alias arrow instead of a folder I can drill down into. At first I figured this might be some kind of bug so instead of a Finder alias I tried the same thing with ln -s and put a symlink to that folder into my dock folder. But same result.

I could have sworn it used to be possible to drill down multiple folders in the Dock even if they included aliases. Am I misremembering? Did this get removed? Bug?

I tried it on Monterey and it seems to work as you (and I) would expect. The alias has a folder icon with the alias arrow, and it behaves the same as a real folder (i.e. I can drill down as far as I want in the “speech bubble” (I’m sure there’s a real name for it and that’s not it) attached to the folder’s icon in the Dock). So seems like a bug in Ventura.

1 Like