Diagnosis Mac Mini

Today I was called into my former employer’s to resolve an issue with a new M2 Mac Mini which had lost the ability to produce video. It had two monitors attached - one by USB-C and one via HDMI - neither was working. Beginning with the obvious we restarted, unplugged monitors, swapped them around, changed monitors, changed cables and nothing worked. At this stage I was worried the graphics chips had been damaged.

I then booted into the Options area (long press on power button) and lo and behold the screen displayed perfectly - suggesting connections between the MM and monitors was fine. I then decided to reinstall MacOS (Ventura) and after about 90 minutes the machine returned to life.

So what’s the point of the story.

  1. No matter what Apple do to secure it, it’s still possible to hose the OS.
  2. The inability to boot from an external clone cost almost two hours of lost productivity. In the past we would have been up and running in about 3 minutes but instead we were forced to do a wi-fi recovery over the Internet. If we didn’t have decent net speeds it would have been significantly longer.

Sometimes I wonder if Apple takes businesses into account when making decisions such as this. When times in our industry are already difficult, lost productivity is a major concern.

Can the Startup Security Utility no longer allow booting from an external disk?

You can boot from an external disk, but the procedure it a bit more convoluted on Apple Silicon than on Intel-based Macs.

The big problem is that it is a challenge to make a bootable clone of a running system. A special (undocumented) Apple software tool is required to do this, and it wipes the destination volume, so you need to make a full backup every time - no incremental backups.

That having been said, Carbon Copy Cloner does include a configuration option to attempt to make a bootable backup using this tool, but they don’t guarantee the result will be bootable and they don’t recommend its use. They recommend a standard backup (of the Data volume) and then install macOS over it to make the result bootable.

See also:

1 Like

I’m running Ventura with the latest CCC and the legacy boot option is no longer available - or if it is it’s so well hidden as to be invisible. I can find no mention on the Bombich site which mentions bootable options beyond BigSur.

I realise the new process is to backup the data drive and restore to a clean Sealed System via either Migration Manager or CCC itself. I’d never trust MA as it’s been horribly unreliable for us in the past and even if it was perfect, the issue is the time it takes. First we have to restore the OS, then migrate the data. What took minutes to be operable now takes hours. Productivity - the reason for which we use computers - is lost.

Clearly Apple aren’t going to change it, but it’s created a major obstacle for us - highlighted by the fact the OS can get hosed so easily.

Since the introduction of macOS I can count on maybe 2 fingers max the number of times that macOS was hosed and needed reinstall. YMMv of course, but I would wager my experience is more widespread than yours.

With SSV it is now harder than ever to “hose macOS”.

Fact.

Here’s the documentation:

Creating legacy bootable copies of macOS (Big Sur and later) | Carbon Copy Cloner | Bombich Software

On my Mac (2018 mini, running Ventura), the option is there. Right-click on the destination volume (it must be mounted at the time), and you’ll see it on the popup menu:

After selecting that menu item, confirm your choice via a window that will immediately pop up:

Screenshot 2023-12-06 at 09.41.58

If you’re still not seeing the option, then perhaps it’s different on Apple Silicon Macs (assuming that’s what you have).

Except that it happened to us. This machine hung and required a forced restart. I’m not saying this is a common thing, but it can definitely happen. Ironically, after looking after literally hundreds of machines over the entire life of OSX, this is the first time I can remember a system failing in this way.

I apologise, you’re right. I didn’t have the backup disk mounted and the option wasn’t showing.

Here’s what Howard Oakley most recently had to say on “bootable clones” on modern Apple Silicon Macs.

Particularly with Apple silicon Macs, relying on making a bootable backup is really foolhardy – macOS no longer supports that. If you care to read Mike Bombich’s documentation on what he describes as “legacy” clones, you’ll see that he also discourages you from trying to use them. Watch my keys: bootable backups don’t work. They break, and raise all sorts of problems. Advanced users no longer use them, because they understand how the architecture of macOS has changed.

Source

I understand how they work and why they’re not recommended. I’m just deeply disappointed it’s no longer available as a simple - and fast - way to recover a working machine. We have around 90 machines and having a bootable clone on each meant virtually instant recovery from any sort of failure (we carry two spare machines).

I think we may be using different terminology.

Nobody is saying that macOS never crashes or hangs. We’ve all had occasion where everything just died for no obvious reason.

The question is whether it comes back after that “forced restart”. If you forcibly power-off the computer (or pull the power cord), reset the SMC and find that it won’t boot without reinstalling macOS, that’s what I’d consider “hosed”, and that’s where having a spare bootable storage device (whether a clone of the original system or not) would be really handy.

If a restart works, then you didn’t actually need that bootable backup. And thanks to the SSV, that level of “hosed” generally doesn’t happen unless your internal SSD is failing.

If you refer to my original post, you’ll see that’s exactly what happened. The machine had hung and the user forced a restart. From there it was no longer displaying video or responding in any way - which is when I was called in. The machine could not be remotely accessed and multiple restarts, SMC resetting, monitor and cable changes, disconnecting all peripherals etc were unsuccessful.

It required a boot into recovery mode and a complete re-install of the OS - at which stage it became functional again. So yes, I consider that hosed.

I’d be disappointed if it’s due to the SSD failing as the machine is only 6 months old.

Did you try, after booting into recovery mode, just booting again in normal mode before you re-installed macOS?

Yes, several times.