Dealing with Microsoft

I was a member of a 4 person, then 3 person after first 2 years, LLC that was engineering for turn key operations the FASOR source for adaptive optics(see FASOR at Wikipedia, Frequency addition source of optical radiation - Wikipedia), three of us left Gov’t cushy jobs to start this LLC to bid on this job: 4 Laser Guide Star Facility | ESO After we didn’t win that job, we fluttered for ten years, but did do this navy job: {note cover photo on that issue} . Which later took me to Alomar Observatory, way north of the arctic circle near Tromsø for two winters to try to use the technique to measure the magnetic fluctuations at 100km altitude during the northern lights.

Well in ~ 2012 I got a 2011 quad core MBP to run some quantum mechanical level code to calculate the guidestar brightness under various conditions, I still have it. It had Mathematica, Matlab, and LabView on it. Upgrading from Yosemite to El Capitan caused these to fail, but I was able to find ways to get them to work again, but discouraged further upgrading. We could not justifying the cost of updating these apps. I also had Micro$hit Office 2011 on it. That was downloaded and product code e-mailed to me. Well during the 6 month dissolving FASORtronics, our MacMini server’s HD crashed big time, and we decided to not try to resurrect it.

Time hole jump to present, as El Capitan can not use the internet any more as all certificates are now void, on an external drive I installed HS, then used migration assistant to move everything over, and booted from it. Everything worked but Office apps, they wanted the product codes. In a world long time ago, there was an app that could extract the product code from office products, but I can’t find it. I looked at all the e-mails from the FASORtronics mail server still in Mail, I had two folders, one for receipts, one for registrations, but can’t find one containing the e-mailed product code. Thus the exercise over the last month trying to talk to intelligence at Micro$hit that could help me (Google and ChatGPT have nothing to worry about MS’s AI). Thus, the chat I had today (when I navigated the webpage today I did not see the option to have a call returned, chat was the only option). I know we all have had our troubles with Apple, but I have not had one quite like this (close a couple of times). (I think I cleaned out any personal information and links to free software) Notice the many questions not answered, and she refers to ‘ac’ several times, I still have no idea what that is. Have a laugh!

1 Like

Not much help to you I suspect, but I run Office 2011 on a Mac running Mojave and have taken a snapshot of the About pop-up that has the licence info, including the Product Code. This information has worked for a Mac replacement.
Good luck dealing with MS!

The only product code finder that I know about ( notes this:

Microsoft Office 2011 is NOT supported by Free or Pro versions, and no, unfortunately we cannot add it, since it’s encrypted, even though we know where it’s stored. Only Office 2008 and beta version of 2011 are supported.

So I don’t think there is a product that can get your 2011 product code :frowning:

If you read my chat with Rita, I mention just that. I tried that code shown in the about box, and it’s not the right format, not enough characters/numbers long. I’d show a screen shot, but that would require me to reboot the MBP via the external disk with El Capitan again to get it. Its now too late, I have to soak my four toes in warm water with epson salt and go to bed (week ago I had parts of both big toe toenails removed to fix ingrown toenails, and both toenails next to them removed as hiking down in 2003 from the TWA plane wreck here in the Sandia’s I damaged both nail beds and the nails grew back black and at 90 deg and real thick (I won an ugly toe contest here on the internet) don’t feel too sorry for me, they really only hurt real bad for a day after local wore off) and I have a 8:30 meeting tomorrow morning.

EXACTLY what I thought, and if you look at my conversation with Rita I say just that! So why don’t they let you use a tool to get the product code? I think, have the code finder app have a 24 hour expiration date, or send the encrypted code to the mother ship to decode and send back.

I downloaded the Office trio from site Rita gave me. It was version 16.43, I had version 14.x, so two version newer, this is great! She said to use my Microsoft account to activate. I tried that, nope, says I don’t have it in my account. Sign into my account, there is a version 16.70 paid for and registered, hey even better yet!. I click the install button, and it downloads. Go to install that, it says it needs MacOS 11.0 to run. Now can I get hold of Rita again? I had a VERY hard time getting to the same person that left a voice mail, with name and ext., for me from Ford, that took me at least 1/2 day and I was unsuccessful, each agent that answered the general number would NOT transfer me, but referred me to some one else, and I went in a complete circle. Two days later, today, luckily the gal that left the voice mail called back, and she DID solve my problem, well not exactly, Ford still refused to refund $100, but gave me a $800 package instead that I can use, go figure. My brother use to do that in the 70’s, book a daytime flight in coach, change to the red eye, and instead of a refund they would move him to first class. Note bad if you can take the red eye, and most grad students can weather it.

1 Like

Apologies for overlooking that. It seems that, in addition to a “Product ID”, you also need an activation code. I have both recorded in a text file (with numerous registration codes) that I have stored on a Bluray disk + backup disks.

Looks like an Office alternative, such as Libre Office might be your best bet (covered in other discussions on this forum).

I visited and stayed at the ESO facility at Paranal for a week, got to see and film the laser guide star in operation. Such extraordinary work.

Was that the single laser guidestar or the quad? Did you watch the james bond movie Quantum Solace, that was partly filmed there? Actually while wondering around the area we did find some chlorophyll! The single laser guidestar was produced with a dye laser, and it took two engineers full time to keep it running. The dye had to be changed I think once a week. On the ESO website I pointed to, under instruments is a photo of the dye laser, it was mighty complicated, we got to examine it for about 1/2 hour and I took lots of photos. Insurance companies did not like the dye laser either as the dye was quite volatile, right by multi 100’s of millions dollars of scientific equipment, Keck could not get a dye laser approved. We were there only for about four days, and the first night was weathered out, we gave our host a good hard time about that. Our FASOR was complicated too, but no messy dye to work with every week, ours was solid state, diode lasers pumped eight Nd:YAG rods. We got to climb all over one of the 8 m telescope to determine and plan where to mount our lasers, launch telescopes, and then cooling lines to the basement were the water chiller/recirculator would have to be located (they didn’t like the idea of such a vibration piece of machinary being that close to the telescope). The bearings for azimuth rotation under the telescope were amazing.

It was in 2015, the observatory itself was fascinating, the team was quite something,

I did watch Quantum of Solace subsequently, the team said the filmmakers brought their own fibreglass ‘rocks’, apparently one or two of them still there!

Toomy, go back and read my comment, I was still adding/modifing when you posted last. You were there later than we were, we were there 2009 or so.

Yeh I know, but I’ve used Excel for years, since version 1. But it is not by far my favorite spreadsheet app. That honor belongs to Full Impact by Ashton Tate. By far better than any version of Excel, but it didn’t make it out of the 24 bit world, due to politics, buy outs, greed, etc. First app to have a tool bar {modifiable at that with your own drawn icons}, could plot 3 D surfaces, and rotate them by dragging the mouse, had a pascal like scripting language in a separate module, where Excel and Lotus had macro lines in spreadsheet cells, and its formulas easier to read, you didn’t do $AND(A,B) but just A&B. On my 64K computer in the early 80’s, its spreadsheet app had a preference you could set to work in degrees or radians, nobody, to my knowledge, yet has that option!

That exchange sure sounds painful! Just trying to get a real person on chat these days is.

But I may have missed this in the dialog - why don’t you remote into your other machine to use Office?

I have a similar issue: I run Office 2011 on my Sierra MBP. I need to upgrade my drive which will move me out of Sierra and I may lose Office. To get around this I tried to install Office on the iMac I use for music and storage. Figured when I’m in the office I would just share screen the iMac like I do with other things, and get one of the free ones for the laptop for on the road. I still have my codes and still couldn’t install it. I’ve since installed a free office suite on the iMac which was needed when I had the laptop battery replaced last year.

Last year I picked up a used Mini with the intent of upgrading it without worries of losing legacy software. I ended up buying a newer version of Office from MacHeist for under $50. I’ve seen the same deal a number of times and it’s a regular license purchase, not a subscription.

I get the frustration of having to pay for something you already paid for, since some of these companies have figured out ways to break software years down the road. But in my case, I’d bought Office 2011 off Amazon around 2015 and got it for a good price ($130 I think) so I didn’t feel I was out that much and the MacHeist deal was sweet.

Just a thought but it’s possible I missed something!


If your main issue is that older versions of macOS had their main rootCA expire and the fact that older versions of macOS will not automatically update/replace these rootCA certificates - unlike more up-to-date macOS versions then there is a way to fix this manually.

Note: This affected just ‘LetsEncrypt’ generated certificates and a very large portion of the Internet use such certificates.

I did this on an older Mac myself and it fixed access to websites for me. The remaining problem is that such an older Mac will also only run out of date versions of web-browsers. This is nothing to do with certificates but down to the fact that an increasing number of websites will check the version of the browser and generate an error message if an older browser tries to load the website. This will be partially down to a concern over security issues in older browsers and partly that older browsers will not support modern html code.

Anyway, if you want to fix the certificate issue then see the following article.


Many reasons, most often other MBP may be asleep (but can it be woke up over WiFi?) What if away? Then keep track on which HD your files are located. Speed. Extra step. And that 2011 version is paid for, so I want access to it, it’s kind of the principle of the thing.

When I first heard the El Capitan certificates were going to/had expired I looked at this or a similar site, and I could not follow.

Yep, the robobots are hard to convince you need a real person. Long past is the days to speaking to flesh on the phone, IF you can navigate the menus, IF the voice rec software understands,IF you can find that option. Then get the flesh to transfer you to the person that CAN solve your problem and not try to do so themselves. After at least a 1/2 day trying to get hold of the person that left me a voice mail, going in a complete circle with another company, recommendation was to phone number I had already talked to, two days later the gal that left the voice mail call me back! Whew. Even she could not rebate me the $100 dollars I thought I deserved and should not have been charged, she gave me an about $800 package as compensation. Go figure. My brother took advantage of the same thing in the 70’s. Book a day time flight, then change it to red eye special, airlines do not like refunding money but don’t mind upgrading you to first class. He did that a number of times.

If it is just a problem accessing secure web sites with Safari, the quickest and easiest solution is to switch to another browser that is still receiving updates.

Unfortunately, Firefox no longer supports macOS 10.11 (El Capitan), so that’s no longer an option.

A bit of web searching shows that the Brave Brave browser still supports macOS 10.11.

Waterfox might work (I couldn’t find a system requirements page).

I think iCab is also compatible.

Unfortunately, several other browsers that people claim to be compatible (Vivaldi, Chrome and Opera) say they require macOS 10.13 or later. And one that should be compatible (Omniweb) hasn’t been updated for a long time, so I wouldn’t consider it secure.

There may be others as well, but I haven’t done an extensive search.

I really get the principle thing, and yes, it is a pain to try to keep “obsolete” hardware and software running. But it’s really not a horrid suggestion while you continue to hunt down MS and force them to cough up the activation code you need (and paid for).

For example, it’s how I’ve kept Adobe InDesign CS6 available long, long past its “we killed it and we don’t want to hear about it” date. Running on a late 2012 iMac, and I screenshare to that machine from my current Mac in another room running Ventura. Yes, it’s not as fast and there are occasional artifacts because my current screen is a 5K Retina display and the other iMac is, um, not.

But it is helping me with legacy projects, which it sounds like you want to accomplish as well.

Good luck with Redmond and its satellites!

1 Like