Check your From address when replying in Apple Mail

I have several @mac, @me, etc. type email addresses I use in Mail. I also have one @gmail address that i rarely use but it is active.

I have my Mail Preferences so I create messages in only an @mac address

This weekend I received an email that was addressed to my @mac.com address. It was sent by an @gmail.com person

When I Replied to the person I discovered that the Reply was being sent From my @gmail.com address. I truly expected it to be from my primary @mac address as that was the address of the incoming email.

This is not the first time that messages had gone out with the @gmail address when I had no plans to do it

We suspect (know?) that Google doesn’t always play nice with Apple Mail. I think this is another example

My “theory” is that If a reply is being sent to an @gmail address Google manages to find an @gmail account to send it from

So, my alert is to look at your FROM address when replying. It may not be what you thought it would be

Jerry

In my experience, Apple Mail does this to be helpful. Also, I suspect Apple Mail remembers which email you used the last time you sent an email to a particular address. For instance, when I forward an article to family members, the email pre-selected is my primary home email, not the work email I usually use.

However, as with everything computer related, sometimes humans disagree with what the computer has “decided”, so it is good practice to pay attention to FROM addresses (and TO - often email gets sent to someone’s old email, or non-primary, or even worse, someone with a similar name).

1 Like

Thanks Seth

I may have accidentally previously sent him an email from the gmail account but not intentionally. and have sent him dozens from my @mac address.
Have to put it down to another mystery of Mail

It might be because gmail considers email with “mac.com” addresses to be invalid. I had to stop using my mac.com address (and my aol address) for emails sent to gmail addresses as they would be rejected. I don’t remember the exact error message but it reffered to some anti-spam protocol that was implement a few years back. Apparently the mac.com and aol.com servers refuse to verify the emails as legit.

I think that’s been at least partly fixed, Dennis. I just sent email from my mac.com address to my gmail address without incident. Examination of the full mail headers showed an explicit indication that the mac.com domain now has SPF records designating the iCloud mail-sending servers as senders.

If so, then it has only been within the last two months as I had problems in May. However, I didn’t have problems sending email to MYSELF, as I think that bypasses a lot of the outside routing. I’ll have to do some testing.

OK, I’m replying from within GMail but using mac.com as my from address as a test.

My test was using the macOS Mail app as the client and sending through mac.com servers.

Since mac.com has SPF records, you should not be able to use Gmail sending servers with a mac.com return address.

Yet, it worked (this time). Here are my settings:

Send mail as:
(Use North Valley Wireless Mail to send from your other email addresses)

Dennis Swaney romad@mac.com

default

North Valley Wireless is my ISP but they contracted with GMail to handle email

I have no .mac nor gmail account but use several at my own domain, and find that Mail ignores my default. My explanation is that, since I don’t let Siri’s “intelligence” make mistakes for me, Apple has sought another way.

I’m not using Mail.app, I’m using my web browser to access my NVWISP mail and it is going via mail.google.com. I used to use Thunderbird, but Apple blocked it from accessing my .mac mail, so I have .mac forward my mail to my GMail-managed NVWISP mail.

In Take Control of Apple Mail, which is the best compilation of information about the app, Joe Kissell says:

The default option here is “Automatically select best account,” but I’ve found this setting to be weird and unpredictable—even more so than the “Account of selected mailbox” option in El Capitan and earlier. Previously, with “Account of selected mailbox” chosen, Mail used the account corresponding to the selected message or Inbox. Now, if you’ve selected a message in a specific account’s Inbox, Mail sends the message from that account. But if you’re anywhere else, Mail chooses what it considers the “best” account, according to a logic I’ve been unable to discern but which has been wrong for me nearly every single time. And, even if you have a specific account’s Inbox selected when you create a new message, Mail might decide to override that account depending on the To addresses in your message. In short: feel free to try this if you like, but expect the unexpected. My advice is: for maximum sanity, avoid “Automatically select best account”!

I think it’s a different situation than what people have been discussing, but I have found that a saved draft will often have a different From account when I open it for editing than it had when I saved it.

And it seems to me that there should be another option in the “Send new messages from:” drop-down menu: Ask me every time.

Will M wrote:

a saved draft will often have a different From account when I open it for editing than it had when I saved it.

It’s all this squirrelly stuff, plus the total lack of accessibility features, that drove me to prefer the Fastmail web interface. I do run Apple Mail on my file server, because with the addition of Mail Tags it does an adequate job of filtering and adding metadata, and spamsieve on top of the fastmail spam filters is close to perfect. I also use Mail to periodically archive older mail to get it offline. But it’s unusable for reading mail - takes about a minute to open a message. I’d blame my server, but I have the same, though less extreme, problem at work.

I routinely encounter that. Interestingly enough, at least in my case it still sends it using the right (originally specified) account, not the one it’s showing.

It’s super annoying and considering how long Mail has showed this bug (and the fact that I reported it to Apple ages ago) and they still haven’t fixed it is just embarrassing. You’d think with $250B in cash, some QA/QC would be possible. Attention to detail used to be Apple’s hallmark.

Succinct and oh so true.

yeah, I think that ship has sailed. After spending countless recent hours trying to configure and/or troubleshoot (in no particular order) filesharing, iCloud, Messages, AppleTV, Pages, Mail, Safari, and probably some other Apple software, I think Apple management should spend more time using their software products in the real world before releasing them.

When did it become Apple policy to release an OS every year? Why not wait a couple of years between new OS (MacOS especially, but iOS too)? Per Wikipedia, Mac OS 10.3 was released in 2003, 10.4 in 2005; Leopard (10.4) released in 2007. Why not go back to that schedule, and spend some more time “paying attention to detail” aka “polishing”?

Sorry for the thread hijack

It’s funny, but I have the opposite experience – I love the “Automatically select best account to send from” feature in Mail. It almost always gets the right one for the address I’m emailing. It doesn’t save a huge amount of time, but feels a little magic. :tophat::woman_mage::blush:

It feels VERY magic, but not so good when it picks the wrong one randomly and I send before I realize it! :-/

Diane

1 Like