Changed site From: address for email messages


(Adam Engst) #1

Another minor site housekeeping thing to note. Previously, the default From address for email messages from Discourse was noreply@talk.tidbits.com, even when it is possible to reply back to the site, as with TidBITS Talk.

I’ve never liked the implication that you can’t reply, and it’s not like anyone doesn’t know my address anyway, so I’m going to see what happens with this From address set to my email. It’s possible that this is a bad idea, or that it should be set in some other way (such as to the TidBITS Talk submission address), but I won’t know unless I test.


(Seth Anderson) #2

Hmm, well on Apple Mail (Mac version and iOS version), all mail is now coming from you, instead of say, “David Price”. So it might be confusing to many


(Diane D) #3

Seth - this one had your name on it, not Adam’s

Diane


(Mark Williamson) #4

When it came into my inbox in the High Sierra Mail application, it showed as just one more “Adam Engst” message in a closer that were all from different people. Only the internal text showed the real originator.

Mark


(David Brostoff) #5

@Seth,

With my setup at least (Mail, 10.13.4) your message came from you and others have been coming from each individual sender.

David


(s.kawalko) #6

With Mail 11.3 and Preferences->Viewing->Use Smart Address disabled, I see the sender’s name followed by ace@tidbits.com in the From field.


(Jolin Warren) #7

I think that people who see this as from Adam have his address in their contacts list (or previous recipients), as this overrides the “From” string set in the email.


(Adam Engst) #8

Hmm… Much as it’s all about me :-), having messages all appear to be from me for people who have my address in their contacts or previous recipients is not good.

I’ll try the TidBITS Talk submission address next—let’s see how that works out.