Can you make a Mac "see" an attached drive?

I’ve had a couple occasions where, after a reboot, my MBP M1 Pro doesn’t auto-mount an attached drive. In one case, it was an external SSD, in the other a card in the SDXC slot. In each case, it’s as if the drive had not been attached/inserted, yet it was. Is there a terminal command (or even a utility app) I could use to force a re-poll of the USB bus? I could unplug/replug the external SSD easily enough, but the SD card is a JetDrive 330, which when inserted is flush with the side of the Mac and is difficult to remove.

I had a similar issue with some externals getting dismounted…solved it with a simple CarbonCopyCloner job that runs periodically and is set to mount the destination of its not there…something like that should work for you.

My first stop would be the standard Apple utility Disk Utility. If the volume is visible there, you can mount it with a button or menu item.

If the volume and device don’t show up in Disk Utility, do they show up in System Information?


Thanks, and sorry, forgot one salient point in my post: The drive(s) are not visible in Disk Utility. But you got me thinking about the diskutil terminal command, and in particular its list option. I’ll try that next time it happens and see if I get any further.

1 Like

Odd that they don’t even show as unmounted in Disk Utility. On previous versions of Ventura I often saw a similar issue with USB-attached drives. However, they always showed in Disk Utility, so I was able to manually mount them there. Fortunately, either the 13.4 or the 13.3 update seems to have fixed the issue for me.

Jeff, do they show up after a re-boot, or a shut down and restart?

Have you run any fixit utilities, whatever you can on your Mac and on the externals?

Once upon a time (on my 2011 Mac mini running Sierra), I would occasionally find that my Time Machine volume (a USB-attached hard drive) wouldn’t re-mount after rebooting. Disk Utility wouldn’t see the drive at all. A power-cycle on the external drive always brought it back.

I always assumed that something in the drive had glitched and didn’t think much beyond that.

Later on, when I upgraded the computer, I upgraded the Time Machine volume to a bigger drive in a different enclosure. The problem hasn’t occurred again, but I have no way of knowing if it was the drive, its enclosure, the Mac or macOS.

In the past, macOS distinguished between an “unmount” and an “eject” operation. An unmount (only possible from Disk Utility) would unmount the volume, but the OS would still know about it, making a re-mount possible. But after an eject, macOS would lose the drive altogether (even the physical volume vanished from Disk Utility), forcing you to either power-cycle the device or hot-plug it in order to get macOS to re-discover it.

But I don’t think this is the case with modern releases of macOS. I’ve seen that after I eject drives, Disk Utility continues to show the physical volume, and I can re-mount the logical volumes without power-cycling the drive.

Since you’re using an M1 Mac, you are almost certainly using a build of macOS new enough that an eject operation is reversible. So I’m thinking that it may be a glitch on your external storage device.

1 Like


Sometimes. Well, the external SSD I’d say nearly always. The JetDrive is too new to have any meaningful data.

So for what it’s worth, I just restarted my Mac, and both drives showed up just fine. So who knows? Maybe it’s a rare case that I’ll just have to deal with when it happens. I’m guessing that when you launch Disk Utility, it runs the diskutil list command behind the scenes, but I’ll at least try that manually the next time it happens and see what’s reported.

That is certainly how this situation “feels.” Interesting to know (inferring from your statement) that there is no “magic command” that would make the Mac re-poll the bus to see what’s out there.

Exactly right. I’m running Ventura 13.4.1 (c), and indeed, if I eject either drive, it still shows up in Disk Utility (with the logical volume name in gray), and in diskutil list. Remounting works perfectly, as you would expect.

This behavior goes all the way back to System 6.

I saw the same thing when power-cycling SCSI devices on my Mac SE. Any device not powered-on at boot time would generally not be available at all, although some third-party disk utilities (like CharisMac’s Anubis) did have a button to force a rescan of the bus, which would mount devices that weren’t powered at boot time. Which I often used with drives like CD-ROMs, which I often didn’t bother to power-on until they were actually needed.

I would be interested in an answer to this question. I’ve run into this behavior from time to time with various USB flash drives across various Macs. Removing the drive and reconnecting always solved the issue. It’s happened often enough that I’m not surprised when it happens but not often enough to notice a pattern or to invest the time to troubleshoot.

Two other circumstances, though these do show up in Disk Utility:

On my Sierra / 2017 imac if a drive is encrypted, even if the password is saved in keychain, a drive may not mount on boot. I’ve had drives where I had to delete that password then let disk utility put it back in again to restore auto mounting. Recently I had a variation of that where I had to specifically allow disk utility to have access to the password that it put there in the first place. (I never the keychain through iCloud, so at least in this case iCloud is presumed innocent.)

I’ve also had a few problems getting everything to mount where lots of volumes are involved (HFS+ spinny drives). When booting with three enclosures, 6 drives and 13 volumes into two usb-c ports, a few often don’t show up even after a long wait. I assume all that input makes DU throw up it’s hands in defeat.

I have not experienced this precise issue but I have several related ones which apply to an M2 Mac mini with Ventura (all releases). (1) on boot-up, the attached Time Machine does not show up in Finder for a minute or two but is visible in Disk Utility. (2) At any time, after attaching an external drive I have to wait 20+ seconds for it to show in Finder. (3) The machine is in sleep mode overnight. From time to time the next day I see messages that an external drive was disconnected without being properly ejected however all the external drives are actually still showing in Finder.
I have an M1 MacBook Air on latest Ventura and it does NOT exhibit these issues.

Interesting. But this was the SCSI bus, no? I wonder if there is/was an app that could force a re-scan of the USB bus?

[Funny how “USB bus” is technically redundant, but somehow sounds better than “the USB”.]

Yes, that was SCSI. But I assume much of the same philosophy is on other parts of macOS - that an ejected device doesn’t exist because you’re expected to unplug it.

After some web searching, I found this old article:

Suggestions (not sure if any will actually work):

  • If there is a Unix device (e.g. /dev/disk* still present for the device, you can try an hdiutil attach command. But ejected devices may no longer have a device (which I would expect here, since Disk Utility isn’t showing it either).

  • Unload/reload the USB mass storage kernel extension. This will unmount and remount all USB storage devices. But this advice was from 2010. I expect SIP and other new security features will prevent this from working today.

    It’s probably also a bad idea if you have multiple USB storage devices.

  • Command-line diskutil: diskutil list and diskutil mountDisk. But that assumes it can see the device. Again, I wouldn’t expect that to work if the graphical Disk Utility doesn’t show the device.

  • Put the Mac to sleep and wake it up again. If nobody else is using it at the time, that may be a good solution.

Sadly, my searching seems to indicate that there isn’t any direct command to tell macOS to rescan its buses for devices. There should be one.


Is it different on a reboot vs a power cycle?

My first guess would be that the device is not correctly resetting when the bus resets, only when the power forces it to.

That’s something I’ve experienced a lot, over the years, with buses of all flavours and versions and seems to be a common issue on a lot of hardware.

Oh, that sounds like it ought to work. Will definitely try that next time it happens. Thanks.

Well, I can’t say since I can’t think of a single time I’ve done a Shut Down on this MBP, and a power cycle doesn’t naturally occur, even if the grid power fails (well, at least not for a long time), But doing that deliberately would be another interesting thing to try, if @Shamino’s suggestion doesn’t work.

The jetdrive I bought 5 years ago came with a utility named ‘auto mount’ or some such that meant it auto-mounted after sleep or restart.

I was having similar problems with an external drive. Carbon Copy Cloner would be unable to find the drive to do a backup, so the backup would fail. but it would show up as mounted in Disk Utility, and not let me unmount it because it was being “used” by something on my MacMini 2018. The only way to find the drive was to restart the Mac (or unplug the USB drive and then plug it in, which I tried in frustration a couple of times, but did not want to continue). I eventually began to suspect a problem with the external (spinning) drive and replacing it did solve that problem – but when I replaced it with an external Crucial SSD (which has a Thunderbolt port that plugs directly to the MacMini), I have regularly encountered error messages when it wakes up from sleep claiming that the drive was not Ejected Properly, although it’s still mounted.