Audio out via USB?

I have external speakers. I can run them successfully from my MBP M1 Pro when I plug them into its audio out jack. I purchased a 3.5mm to USB-C adapter (not Apple’s) hoping to plug them into my TB4 hub and eliminate one more cable to unplug when I want to go portable. But when I plug the adapter into the hub, all I get is a steady hum on the speakers, and no indication in either Control Center or System Preferences > Sound that they are available to be selected for sound output. I see the same behavior if I plug the adapter directly into a USB-C port on the MBP. What am I missing?

Can you share the brand/model of the adapter, preferably with a link to a product page?

It might be that this isn’t a headphone adapter. Perhaps intended for use with a microphone (line-in jack) or something else.

It’s the MOSWAG Headphone Jack Adapter:

Did you see and select USB Audio from either the Control Center, Sound Preference, or the menubar speaker dropdown? The switch from the internal speaker did not happen automatically as it does when the speakers are plugged into the headphone port on the computer.

Here are the components I used to test this:
14" new MBP
A VAVA USB-C hub with a headphone port among the various ports
Grado SR80 stereo headphones.

There were no issues when plugging the headphones directly into the computer’s headphone jack. The Sound dropdown from the menu bar showed External Headphones as the output and the sound quality was excellent.

I then plugged the headphones into the VAVA hub and the hub into the computer. Initially, there was sound from the internal speakers on the MBP (actually sounding reasonable). From the Sound menu dropdown, I changed the output to USB Audio and the sound switched to the headphones. The sound quality appeared to be the same as when I used the headphone jack.

So, when using a USB connection, you must manually select the speaker. Otherwise, everything works as if it were plugged into the headphone port.

Jeff…it’s either something with a headphone to USB C adapter, M1 computers, or Monterey…I have a similar issue.

Apple earbuds with the phono plug and the Apple USB C adapter. The earbuds correctly interrupt speakers and provide audio when plugged directly in…but with the adapter do not work until I select the USB C earbuds that show up in Control Center. The same earbuds and adapter do transfer audio when plugged into my iPad Air 4…so likely not the adapter but M1 or Monterey. We had a thread about this week and there wasn’t a solution beyond don’t use the adapter or use CC to switch the output…doesn’t seem very user friendly to me…one would think that if Monterey recognizes the adapted earbuds when they’re plugged in that it would follow you wanted to listen to them.

I hate to say it…but Apples software QC is slipping…they advertise all these geewhizbang features at WWDC and end up pulling them before release…like Sidecar or whatever the name is…and simple things like “I plugged in some earbuds…transfer audio to them” don’t work.

1 Like

Yep…that’s the way it works…and whoever made that decision needs their head examined. Audio should switch to speakers or earbuds if they’re plugged in…otherwise why would they be plugged in. And the behavior…whatever design decision they made…should be consistent between the audio jack and USB. What were they thinking?

1 Like

Because a generic USB audio device is not necessarily a pair of headphones you want to start wearing.

For instance, one of the devices I use is a Jabra desktop speaker/microphone device. I absolutely do not want my audio to transfer to it when I plug it in - I only want to use it with conferencing apps.

The operating system doesn’t know that this USB device is a conference speaker and another is a headphone and another is a speaker set. They’re all just USB audio devices.

Nope…control center identifies the Apple earbuds with the Apple USB C adapter as USB-C to 3.5mm headphone jack adapter…so it isn’t recognizing them as a generic USB C device but as headphones…and hence they should cut out the speakers and play via the earbuds as if you plugged them into the 3.5mm jack.

That being said…and I had already tried this several times since last week…just now when I plugged them to verify that they were recognized as earbuds and not a generic USB audio device…they worked as expected and it didn’t matter whether then were already plugged in when audio started or afterwards…

So…something changed since last week, dunno which…but last week I tried the same experiment in the middle of the other thread and audio consistency stayed on the built in speakers rather than switching as it should.

I had originally asked this question on 11/28 which is well after my last macOS update…so I have no idea why it works now and didn’t work before. I understand your argument about generic USB audio devices and that sorta makes sense…but they’re identified as earbuds via a 3.5mm jack adapter…just like they were last week when I asked because it made no sense to me then. I do have “Install system data files and security updates” checked in Software Update but nothing appears to have been installed since the 28th…shrug.

Interesting. I could still argue that this may be correct, since other things can be connected to a 3.5mm jack (e.g. my Klipsch speakers connect to my Mac mini this way).

But that’s a matter of opinion, and it’s not how a built-in headphone jack works. On my Mac mini, when I connect my speakers to the jack, the default output device does change to it, even if I manually selected the built-in speaker before disconnecting the plug. (I personally don’t like this - I think macOS should remember the last output you manually selected and only switch if that device was the headphone jack.)

I find it interesting that the behavior for the USB adapter recently changed without a software update.

Does it matter if there are headphones connected to the adapter? If the adapter connects the jack’s internal switch, it may report the device differently when something is or is not connected to the adapter.

For that matter, I should ask the same to @fischej. Plugging in a bare adapter without any connected headphones might be presented like a built-in headphone jack with nothing connected - which (on my mini) causes the port to not appear in the system settings.

Thanks @neil1, @Shamino, and @aforkosh. Sorry if I was not clear in my original post. I don’t expect sound output to switch automatically.

At David’s request I plugged in the bare adapter to the hub (previously I’d always had the speakers plugged into the adapter first). Lo and behold, there’s the adapter in System Preferences > Sound! (named “ATE1133”, if that makes any difference.) It is listed as “USB” under Type. It does not appear in Control Center. However, selecting it as the output device and plugging my speakers in still doesn’t work. Nothing but a hum on the speakers.

So I believe I’ve learned 1) This approach should work, 2) The adapter I bought is either broken or not designed for Mac.

Thanks guys! As always, the info I get here is unparalleled.

It is definitely starting to sound like a defective adapter. Or possibly a short in the cable.

If the speakers work when connected to something else (do you have a phone or iPod with a headphone jack for testing?), then I’d ask the seller to exchange the adapter. If that doesn’t work, try a different model.

BTW, in case you’re curious, “ATE1133” is the chip that’s driving the adapter. The fact that they didn’t bother to rename it tells me that the manufacturer is probably shipping the same firmware that the chipmaker pre-loaded, without any customization whatsoever. A web search finds only pages in Chinese, but Google Translate seems to work if you’re curious about it.

It’s appears to be a generic USB 2.0 audio adapter, featuring mono microphone-level input and stereo headphone-level output. The description indicates that it’s designed for use with Android headsets, supporting in-line buttons (play/pause/volume/etc) as well as mic/speaker capabilities. But since it claims to comply with the USB audio and HID specs, it should be compatible with everything.


I find it interesting that the behavior for the USB adapter recently changed without a software update.

Yeah…me too. I can’t find anything that changed but I verified the problem a couple times last week and actually logged out and in as another non admin user to see if that changed anything…it didn’t. And I’ve verified a couple times today that…now…it works as I expected it to.

Does it matter if there are headphones connected to the adapter? If the adapter connects the jack’s internal switch, it may report the device differently when something is or is not connected to the adapter.

The adapter by itself doesn’t show up in Control Center and doesn’t change the audio destination. Plugging the earbuds into the adapter with it already in the USB C port correctly switches the output to the earbuds and the 3.5mm earbud to USB C selection shows up in CC…at that point, unplugging the earbuds from the adapter restores speaker output and removes the CC selection, plugging them back in restores and switches to the earbuds. Removing and reinserting the adapter to the USB C port switches as expected.

Strange indeed…

So just to close out my part, I replaced the MOSWAG headphone adapter with Apple’s. The Apple adapter works flawlessly. FWIW, I was finally able to get sound out of the MOSWAG to a pair of earbuds, and then when I plugged in my external speakers, I actually did get sound out of them for the first time, but there was a very loud hum making it an unacceptable alternative in any case. Also FWIW, the Apple adapter shows up in both Sound Preferences and Control Center, and has the eminently reasonable name “USB-C to 3.5mm Headphone Jack Adapter.” Score 1 for Apple-branded peripherals.