Apple Ships Mysterious macOS 11.5.2 Update

Is it the case that Apple waits on release notes for security patches until a patch with applicability across multiple OS/products are all released? (It would be great if this turns out to be the fix for the accursed Pegasus vulnerability!)

Seemingly not all Macs are included. My wife 2018 iMac has no idea that an update is available. Maintains that 11.5.1 is the only current version. Tried to download the update from the App Store, it is there, but her iMac refused to install with the Message that the File Violated the Gatekeeper. On my 2019 iMac there was no issue.

When that happens, the listing on the Apple security update page is there, but not linked. In this case, it explicitly states that there are no CVE entries.

1 Like

Just noticed this. Haven’t installed yet. After my 11.5.1 update my handoff from my iPhone to my Mac is all working again! I’d hate to see it break with another update.

Installed 11.5.2 today and found one bug fixed: iPhone was not “Show[ing] when on Wi-Fi” in Finder previously on my M1 MacBook Air, despite all settings set for it to Show.
It is now.

One other bothersome issue remains–AirPlay audio does not work. Any others having issues with AirPlay audio?

I looked to see if there was any adverse information about the update, didn’t find any, so I installed the update. The only issue I have is it seems that RAM usage is about 15 to 20% heavier. It gets worse if I have Word open which has always been a memory hog for me. I can reduce it somewhat but it only climbs back up to near 80% with use. Since I only have 8 GB RAM, this is an issue.

I’ve installed 11.5.2 on a late 2019 iMac and do not notice any differences.

I remap mu CAPS LOCK key to ESC; and after installing 11.5.1, there would be a pause (beach ball) everytime I hit the CAPS LOCK; that didn’t happen if I used the actual ESC key. Doiing a safe boot and then installing 11.5.2 seems to have cured that behavior.

I did find one thing tonight that has changed with the new update! You can no longer upload any file through WeTransfer or WeSendIt. You can sign on to those sites and even load the files you want to send. But when you click on Send or Transfer it fails. WeSendIt says that Safari cannot make the connection for the transfer. WeTransfer simply says the Transfer failed, try again. I disconnected my VPN and Content Blockers but that made no difference. I checked the site status on both services and they were having no problems.

Then I tried the brand new FireFox on the same sites with the same files and they uploaded and transferred like lightning.

Has Apple done something in this new 11.5.2 to inhibit usage of these sites or is there a problem with the connections it is making? I am unsure but this is very strange. Have used both of the mentioned services for 3 years with never an issue… that is to until Big Sur 11.5.2.

So now, in addition to having to check that apple has turned on bluetooth, game centre and the other things they routinely, but not always, turn on with updates, I have to remember and go through all my accessibility settings? Sheesh.

Slight subject change, but it seems that turning things on with updates is well known and might be a cause here … anyone know WHY they do this? Malice or incompetence?

Why not both? Welcome to our little group!

The article talks about the changes in macOS 11.5.2 Update. It is a page in Japanese (sorry,) but includes a few references to posts (in English) to Twitter/Reddit. They seem to say something about the Caps Lock key and the Touch Bar.

That would explain why it only happens sometimes, indeed. And thank you :slight_smile:

And also emailing a web page in reader view is a neat way to send a readable copy of a webpage to someone complete with pictures and captions!

After installing 11.5.1, I had trouble with scanning software of HP and Canon: no permission, file not found, scanner not found…

Re-installing from their web sites: no help.

After updating to 11.5.2 scanners worked fine.

After the reboot of this update the box in Preferences-> Accessibility > Privacy was empty. Been unable to re-add RescueTime and other apps (Bartender, Magnet, DropBox) there. The apps)complain when starting but the suggested actions to give them permissions (again) don’t work.

After a extra reboot this issue is fixed!

1 Like

Mac Mini M1 with OS 11.5.2 & Bluetooth Mouse A1657
Problem: Cursor works, Clicking does not. No Bluetooth remedies found.
Culprit is in System Preferences> Mouse Panel> Point & Click> Secondary Click.
If checked, Cursor works but Clicking does not.
Used wired Mouse to find and fix as Bluetooth Mouse is neutered when checked!

Now Apple is trying to twist my arm, by sending a notification (daily) stating - “The upgrade will happen tonight” - I have to manually postpone the update. I do NOT want this happening.

What is going on??

Why do you not want this to happen? I’m not seeing any major issues with the update and it has fixed a few lingering problems (more than I expected, actually, based on what was changed).

Sounds like your prefs have been set to download and install automatically. You can turn that off so that you remain in control.

Sys Prefs > Software Update > Advanced

Make sure “Install macOS updates” is deselected as well as “Download new updates when available”. If you have “Check for updates” selected Apple will nag you enough more than all the time, so rest assured you won’t miss anything new.

Also, whenever you get a macOS notification about new updates, you need to make real sure not to click the wrong button. There’s usually a Details… button that pops up somewhere if you hover for long enough. And then you can usually just quit whatever comes up. But you need to make real sure not to mistakenly let it update if that’s not what you want. Apple deliberately makes it hard to just say “no, go away, leave me alone”.

Yup, you have to put in some work to restrain nannyOS™.