Apple Releases macOS 10.14.6, iOS 12.4, watchOS 5.3, tvOS 12.4, and More

Originally published at:

Apple has released macOS 10.14.6, iOS 12.4, watchOS 5.3, and tvOS 12.4. In a surprise move, the company also pushed out iOS 10.3.4 and iOS 9.3.6 for older iOS devices that can’t run iOS 12.

1 Like

I received a notification concerning Security Update 2019-004 High Sierra yesterday afternoon. I assume that Security Editor Rich Mogull recommendation concerning updating macOS 10.14 quickly also applies to macOS 10.12.


Security Update 2019-004 for High Sierra was another one of these annoying updates that had to be run twice. Including downloading the ~2GB installer TWICE. Here’s a piece of advice: do not attempt to install several updates at once. Instead do all but the security update. Then, once that’s the only left, do that one.

Yes, Rich was particularly concerned about all the remote attacks and especially the Bluetooth one.


Geoffrey Staines

So, this is odd (and somewhat concerning). I ran App Store this morning on my High Sierra machine and it said I had two updates, a security update and Safari. I installed Safari, and that seemed to work fine, then I installed the security update, and it did what appeared to be the usual things (I was working on another machine so not paying complete attention).

However, after it rebooted, I ran App Store again, and it shows no updates available, but the last update and only update in the last 30 days is Safari. No sign of the security update.

If I look in /System/Library/Receipts, the bom and plist for the Safari update are there, then 4 minutes after that, there’s a It’s the only macOSBrain in the directory. The last security update is on May 16th (can’t remember if I installed it right away or not, so it may have been released earlier). The macOSBrain bom only specifies /usr/libexec/atomicupdatetool, which does exist and was last updated today at the same time the macOSBrain bom and plist were written.

So it looks like I don’t have the latest security update installed, but for some reason whatever’s checking thinks I do and isn’t offering it again. That’s… worrisome.

The moral is to check that everything that should have been installed shows up in App Store. I’m not sure how to force the security update to be installed, but will investigate further.

Addendum: The security update is downloadable from I’m downloading it now and will see what happens when I install it from the dmg.

That sounds related to what I reported above. It’s not the first time people are reporting things like this with Sec Updates on HS.

Ok, installed the downloaded security update, and now things look normal. It shows up in the App Store as an installed update, and /System/Library/Receipts has the bom & plist for 2019-004 (plus 3 other new bom/plist pairs).

Yes, I saw your post, and have had the double update happen before, and I even took your advice and installed Safari first then the security update. :slight_smile:

While the double update is fairly annoying (I wish I had the infinite free bandwidth everyone at Apple seems to have), missing the update seems much more insidious. At least with the double update it eventually gets installed. If I hadn’t been aware of update issues and looked closely, I would have been running without the update.

It seems that Apple has pulled the Security Update for older versions of macOS temporarily after some MacBook Pros were kernel panicking after being put into sleep.

On the assumption that Apple will fix this quickly, we’ve just held our Watchlist item about the Security Update, since we hadn’t published it before Apple pulled the update.

They also pulled the 10.14.6 BridgeOS update that is required for older T1/T2 equipped Macs, so they are no longer able to apply the 10.14.6 update. It’s thought to impact:

  • 2017 iMac Pro
  • 2018 Mac Mini
  • 2018-2019 Macbook Air
  • 2016-2019 MacBook Pro with Touch Bar.
1 Like

It seems that if you update to 10.14.6, you may have serious performance issues with VMware Fusion virtual machines. If you rely on a Windows VM in Fusion, it would be a good idea to wait until VMware (or Apple) has addressed the problem.

This may be a little obscure, but I have a first generation iPad Mini running iOS 9.3.5. Needless to say, it has some problems accessing websites, etc. but I don’t use it enough to have felt a need to replace it just yet. When I saw there was a 9.3.6 out, I thought this might help with some of the difficulties I’ve been having. But I just got around to checking for updates on the device and got a message saying my OS was up to date. What about 9.3.6?

There were definitely updates posted for

  • iPad mini (GSM/LTE) (iPad2,6) — Download
  • iPad mini (CDMA/LTE) (iPad2,7) — Download

If you don’t have a cell equipped iPad, that would explain it, as the update only addressed problems with those.

If you tried using OTA update, try again with iTunes.

Yes, it’s wifi only. That explains it. Oh well…

Thanks as always!


It seems that the deadline to update to iOS 10.3.4 on an iPhone 5 or iOS 9.3.6 on an iPhone 4s has now passed, so if you haven’t yet updated, you’ll need to back up the iPhone to iTunes, erase it, and restore to get the new version that has fixes for the GPS time rollover issue. If you don’t install the appropriate update, GPS locations reportedly won’t be accurate.