Apple Releases iOS 15.3, iPadOS 15.3, macOS Monterey 12.2, watchOS 8.4, tvOS 15.3, and HomePod Software Version 15.3

Originally published at: Apple Releases iOS 15.3, iPadOS 15.3, macOS Monterey 12.2, watchOS 8.4, tvOS 15.3, and HomePod Software Version 15.3 - TidBITS

Apple has updated all of its operating systems with bug fixes and security updates but no new features apart from Siri on the HomePod learning to recognize two new languages.

1 Like

It continues to be frustrating that Apple will not document what’s been fixed in any of the releases (other than security fixes, which they could do a better job with as well).
They don’t have to include it for the “average Joe” user, but for those of us a little more technically inclined, it might be nice to be able to find that information somewhere…


I look forward to finally trying cmd-L with this updater.

It might be Ctrl+L

This update has still not fixes the messages app not sending sound or banner notifications. Many people have complained to apple about this but the problem has not been addressed. You never know you have a new message unless you check for yourself!

1 Like

This time I have the privilege of knowing one bug that has been fixed. I wrote SDXC card slot in M1 MacBook Pro misbehaving. This problem is now fixed. Now I love my M1 MacBook even more.


I continue to have charging issues for my Watch 6 since updating to WatchOS 8 and, once again, v8.4 has failed to charge post update…

Something else is fixed! My Carplay after 15.2 updates, would not longer default to current song or last song I was listening to prior to removing phone/leaving car. It would default to Library instead, leaving me select back two clicks on my car’s selector (control knob on Mazda).
Well, seems 15.3 fixed it (put the “feature” back, instead of breaking it) and now the song I was playing, or stopped at when leaving the carplay, works properly.

1 Like

I had a very irritating error message when trying to update stereo Homepods from the Home app on my iPad. It kept saying my icloud password was incorrect. This bug has been mentioned in Apple Discussions but is the first time that I have encountered it.
Eventually I tried changing the default audio output of my ATV 4K from the Homepods to the TV and was then able to update the Homepods. After that I made them the default output again.
Apparently 15.3 fixes this bug but, catch 22, you cannot update to it under some circumstances!
I experienced a minor bug with tvOS 15.3. After the update the mute button on the Remote would not restore the sound. Fortunately restarting the ATV fixed the issue.

I was pleasantly surprised last night when I received a notification that the first Time Machine backup had successfully completed. Time Machine never worked on my M1 MBP until now. It looks like Apple fixed the bug in 12.2.

I saw the incantation as both cmd-L and ctrl-L. But alas, neither did anything for me. Just updated from 12.1 → 12.2. Invoked both at several points along the way. Neither was acknowledged at all until I got to the stage where the time remaining was shown. After that, both simply got the System Beep tone (I’m sure it’s not called that anymore).

Maybe off-topic because my comments are in the context of Big Sur.

It might not have been just an earlier version of Monterey. I had problems with Time Machine not completing backups after an update in Big Sur until it just started working. Maybe it was related; maybe not. Anyway, I’m glad the backups started completing, for both you and me.

Same here when I upgraded from 11.6.2 to 11.6.3.

This probably is a rather useless reply about installing Monterey since it’s so late in the game. But since I’m not the only cautious person out there, I’ll write it up briefly.

I installed Monterey 12.2 on my late 2015 iMac the other day, largely because I discovered I had somehow downloaded the 12gb file without really realizing it. And I’m nervous about installations, always worrying something is going wrong when everything takes longer than you’d like. But no, it all worked perfectly. No problems at all. And everything seems to be performing just fine. What more can I say except that I’m relieved and happy.

Do you have an SSD or mechanical hard disk? My fusion drive is what keeps me on High Sierra.

I have a 1tb fusion drive on my late 2015 iMac. About 760GB is free.

Just to close the loop on the Control-L or Command-L trick for seeing the log during install… I found more details about this at Scripting OS X, but as comments on that article suggest, Apple removed the feature. I tried every associated keyboard combination I could think of during the last Monterey update, and it didn’t respond to anything.