Annoying web history

I’ve just replaced my Mac Mini with a new one with the M2 Pro running Sonoma.
I also have a relatively new iPad Air running bang uptodate.
The mini is used for work. The iPad is used for leisure.
Since getting the mini, Safari on both the mac and the pad are driving me up the wall. Search history on one is showing up on the other. this didnt happen with the older mini.
This is making work rather frustrating as all my leisure pages from the ipad are listed above the work pages from yesterday on the mini.
I have searched everywhere for a way to kill this but either I’m too stupid to find it or it is not possible.
Please can someone in our learned community tell me it is possible and how to do it.
PS. I’ve got Hand-Off turned off but it hasn’t changed anything.

I’m assuming both devices are signed in to the same AppleID and Safari is set to sync through iCloud. Turn that syncing off on the Mac mini and it will stop listing your iPad history. Beware that also means no bookmark syncing between the two.

Settings > Apple ID > iCloud > Show More Apps… > Safari to OFF

Or on the iPad:
Settings > Apple ID > iCloud > Show All > Safari to OFF

Set up a Safari Profile for work and one for leisure.

1 Like

Thanks guys.
Simon’s suggestion has worked a treat.