An External SSD Gave My iMac a New Lease on Life

Yep…straight from OWC…although the OS will install fine to an OWC SSD…the only way to get 5he firmware update is to reinstall the original…and it must be in the laptop and not an external case. This is one of their Aura Pro SSDs in a 2015 rMBP…I’m not sure whether this issue is isolated to that model or whether it’s an issue with all OWC SSDs. The problem is that you don’t know the firmware is out of date unless you run a utility that the name of escapes me right now but I’ve got it installed on the laptop and it reports out of date…and thee is no stand alone firmware updates from Apple. Mine has been out of date since probably Mojave or my be the one before that…I’ve considered popping the original back in but as it hasn’t caused any issue for me it never got very high on the priority list.

I’ve talked to OWC support several times and always get the same answer…but no answer as to where the root cause of the failure lies…my guess is something on Apple’s side as OWC acknowledges the issue and if they could solve it via a firmware update on the Aura Pro I would think they would have done so.

Think any of this would be worth exploring (or even possible to explore) for a beloved 27-inch, late 2009 iMac? Of course, it has only these ports:

  • One FireWire 800 port; 7 watts
  • Four USB 2.0 ports

… so probably not?

You could get a bump of a fewfold (maybe as fast as four to six times) on the internal drive if you were willing to crack the case, but I doubt it’s worth the risk. A FireWire 800 drive would only be marginally faster than a 5400 rpm internal drive. However, it’s not clear how processor bound operations are, so you might wind up having put in the effort and minor expense, and find yourself not noticing the upgrade.

Are you implying the EFI firmware?
I just confirmed this, that my version is at and should be much higher. But there has been no update (I am on Big Sur 11.2.3 on a retina MacbookPro 13" Early 2015 12,1) other than the OS updates since I had to use OEM SSD w/High Sierra to install the OWC SSD.
I am running an OWC Aura Pro X2. In 2019, I ran through this problem when I had recycled this MBP with a failed Apple OEM SSD and someone (Thank You, Matthais from Wisconsin) sent me a free Apple OEM 128GB SSD they no longer used. I was able to have High Sierra installed to get the EFI updater 1.0 install from Apple. Then I could install the Aura Pro X2. Its been working fine, but now I did some research … ver4 discusses firmware version and their downloads has the utility Lockrattler that will show firmware version, along with other versions like Gatekeeper, etc.

The eclecticlight discussion thread at the bottom, shows that someone else had OWC SSD installed, like mine, and confirmed that Apple does not update EFI firmware where a 3rd party SSD is installed. I may now have to find the SSD (apple oem) that had HighSierra and update to Big Sur to see if it updates the firmware.

Update: :nerd_face: ah heck with it…I found the OEM SSD I was donated and opened up my MBPro, swapped SSD from OWC Aura Pro X2 back to a 128GB Apple OEM SSD and consumed about an hour of time. With Mojave latest Security update, and 10.14.6 update, my BootROM went from to 426. ! I am now upgrading it to BigSur to see if the version changes–eclecticlight ver5 suggests it will remain at 426. This is correct- I verified…and eficheck had no issues. It did under

*I realize that this probably is moot to those using external booted SSD, but if you replace the internal with OWC Aura Pro X2 product, it looks like it won’t update firmware with each OS update/upgrade. So don’t discard that OEM SSD if you’ve replaced it.

My iMac18,3 updates firmware regardless of whether I’m updating the internal or one of several external drives.

I don’t think that’s right. The internal interface on those models IIRC was SATA and used for primarily HDDs at the time. That would put a cap at about 6 Gbps. The reason ready-to-use quality TB SSDs don’t use SATA but PCIe internally is because of that cap. Even 10 Gbps TB1 equipped with a decent PCIe SSD should outperform anything SATA-based.

I say that as somebody who uses lots of SATA-based SSDs over paltry USB3. But I use those for backup and testing, I wouldn’t routinely use that as boot partition. For comparison, my stock internal SSD pushes >20 Gbps.

Oh, that makes sense. I was thinking of the PCIe internal bus as being faster than Thunderbolt, but I see from the specs that it’s as you say, 6 Gbps.

Yep…EFI firmware as your update notes. At least on 15 rMBP…firmware doesn’t get updated without an original Apple SSD installed. I’ve got the original still and could pop it back in and update to BS…but just haven’t done it. No real reason other than lazy…but I will try to force myself to set aside some time and do it.

Doug…is your external SanDisk SSD faster or slower than the internal one? I’ve got the same model iMac and it’s running out of space even though I’ve got an OWC RAID with almost all the data on it…I a considering an OWC Envoy Pro myself (I’ll look at the SanDisk Extreme Pro as well…but if it’s slower than the original Apple SSD it will be less than fully satisfactory but I’m not going to open up the iMac to replace the SSD.

I have a late 2013 27" iMac that has decided it can’t wait for Apple to release the new iMacs and wants to die sooner :slight_smile: I was going to order a new SSD as a backup drive for the new iMac anyway, but I have bitten the bullet and ordered a Crucial CT2000X8SSD9 2TB X8 Portable and hope it will work well enough to keep the 2013 machine going until the new machines are released.

Neil, I am not sure but it seems a bit faster. I saw no real difference in accessing items on the drive but I only ran it briefly (no time to sign on to numerous items as I was using the disk). When I get some time I am going to give it a more complete “sign in” with various items, but I was really impressed - even with the initial boot up. Hope that helps.

BTW I read where OWC has a new super fancy and fast SSD but the cost looked a bit out of my range.

The Sandisk Extreme Pro is a USB device not Thunderbolt. It will work plugged into Thunderbolt ports but not operate at Thunderbolt speeds. Also macOS sees external thunderbolt devices as virtually equivalent to the internal drive, but this is not the case for externals. The most obvious things not supported on external USB devices are TRIM and SMART. These probably don’t matter in practice but there are advantages to having a full Thunderbolt external.

Out of the box, anyway. There are kernel drivers you can install which will make this information available. Unfortunately, the most popular such driver, Kasbert’s OS-X-SAT-SMART driver hasn’t been updated for many years, so I don’t know how compatible it might be with current releases of macOS. At minimum, I suspect you’ll need to recompile it yourself since I don’t think the installer images are signed, which Apple absolutely requires for kernel drivers.

On the plus side, it appears that BinaryFruit (makers of DriveDX) distributes and supports it (at least for use with DriveDX). I don’t think they’ve changed any code (their fork of the GitHub page is in sync with the master repository), but they have compiled it with the latest tools and have signed it with their developer ID, so I would expect their builds to work without too much hassle. DriveDx - External USB / FireWire drive diagnostics support.

I popped the original SSD back in yesterday afternoon and updated it from Mojave to BS and EFI got updated…

Yeah…I’ll upgrade to either that one or the SanDisk Pro Extreme or whatever it’s called if I run out of internal drive space…everything data-wise actually lives on the attached TB3 OWC RAID…but since I keep Mail running on that one all the time as well as it syncing our full DropBox household account the /Users is pretty large. I know I could move DropBox to the RAID and that would help a little but sometimes the RAID magically dismounts itself for reasons that nobody including me understands.

@mikebhm thank you for your feedback. Yes, it is a USB device that I connect with my Thunderbolt 3. My point is that is seems to be very fast and I was able to successfully boot up the iMac from it and did not see any significant reduction in speed, in fact it seemed a bit faster, but that was on a single try and I didn’t go very far with it.

The OWC device I mentioned is OWC ENVOY PRO FX, which has been well reviewed but is a bit beyond my wallet - $499 for a 2 TB drive ouch! I’ve tried to sell my first born to get one (despite his protests, and given he is 50 yrs old and has 4 black belts, I cancelled the sale lol). It looks ideal and I have never had a bad OWC product, especially their RAM for the iMac!

I DO still worry that the blasted bug that declares at random that various backup disks and CCC disks I’m using will no longer allow me to write to them and I have to backup the data and reformat the drives. It happens with such regularity and with no seeming reason. I am so careful about mounting and unmounting disks and with what I am doing with them. It is not like it is just CCC disks but ordinary data disks where information is saved.

Yes DriveDX and SATSMART driver will enable full SMART support, and while checking the versions to write this I discovered that SATSMART has been updated for both Apple Silicon and Big Sur…so just installed it but can’t get it to work! More info here and here. There is an update for Intel Big Sur too.
Not aware of a driver download for TRIM that works for USB though.
EDIT. Got the new SATSMART driver working…started from scratch and this time remembered to disconnect everything before installing…but not working for Samsung T5s. Ok with other externals including SSD and HDDs.

Were you having problems due to the EFI not being current?


@dougeddy, yes I agree the Sandisk Pro Extreme should work fine as a boot drive and subjectively seem little different from the internal. TRIM and SMART are not essentials. And for a 2TB version price is significantly different for a TB one over a USB one.