AirPort Utility Can't Find AirPort in Bridge Mode

I have an old Airport Extreme that has been solid & stable for many years. Several months a go I received new equipment from my ISP, a combined modem/router. I did not want to use their router for my internal wifi, so I put the Airport in bridge mode. However, when I recently tried Airport Utility, it could not connect to the Airport, saying “device not found”. Thankfully, my internal wifi network continues to work normally but I can’t change anything or use Airport Utility to troubleshoot if something goes wrong. Anyone faced/solved this issue?
Peter Donlevy

Try connecting it directly through Ethernet to your Mac. Use that setup to reconfigure it.

If you don’t want to use your ISP’s wifi, it’s the ISP’s modem that needs to be set to shut off wireless. If you set the AP to bridge you’ll have the ISP’s modem/wifi manage all and the AP will simply pass through whatever the ISP’s modem does. But if you want the AP to essentially manage all traffic then you need to set it up to host its own wifi and make sure the ISP’s wifi is off. In some instances this can lead to double-NAT. That by itself does not necessarily have to be a problem. Depends on what exactly you do.