2023 Apple Watch Models Add Double Tap Gesture

Some thoughts and observations after using the Apple Watch Ultra 2 along the Annapurna Circuit for 29 days:

  • The bright display makes reading the display easy, especially during sunny day on exposed snowfields.
  • The GPS feature seems to work really well. I have the iPhone and Watch on flight mode but with Bluetooth turned on, and I was able to log the tracks accurately whether the Watch is exposed or under layers of clothing (including mountaineering mitts).
  • Altitude measurement seems to work fairly well, but I think it is better to treat the measurement as “ballpark figure” than accurate, to-the-meter/feet measurement. I reviewed the altitude of villages I stayed, and they are generally accurate to within 10m or so; pretty good considering the fact that the villages are generally uneven and located on slopes, so the place of measurement matters. On the highest point of the trek (Thorong La), the Watch measured 5,403m whereas the reference altitude is 5,416m. Again, probably not to be used for accurate mapping but great for tracking general progress.
  • There is no facility to enter backpack weight into the Workout app, and that matters greatly especially at higher altitude. I am taking the performance measurements (cardiac health, etc.) with a generous pinch of salt.
  • Battery life is generally adequate (and even great), even on 10-12 hour trekking days. The charge level never dropped below 20%, but generally would drop below 50%. This includes wearing the Watch during sleep. Daily charging is necessary.
  • It is impossible to operate (or even read) the Watch while wearing mitts, but that is to be expected. That means the Watch is probably not suitable for use when climbing 6,000+m peaks, despite Apple’s allusion that it can be used for ‘extreme activities’.
  • However, it is infuriating that I cannot start a workout by tapping the display while wearing liner gloves, even when I can interact with the screen normally when using other functions while wearing the same pair of gloves. I have to remove the gloves (and mitts, when I wear them) and trekking poles, just to be able to tap that one button. Nonetheless, it worked fine subsequently with another pair of gloves; this might be an issue specific to that pair of gloves.
  • After completing the trek, there was once when the Watch was suddenly not responsive to touch input, and seems to be afflicted by ‘phantom input’ where the display receives ‘random input’ when there was none. At one point, I removed the Watch from my wrist, the display promptly receives a bunch of passcode attempts, and I was locked out of the Watch. I solved the problem by unpairing then pairing the Watch again to the iPhone, and the problem has not recurred since. I suspect it is a software bug rather than a hardware issue.
  • The lesson of the story is that while Apple Watch is great, do not rely on it (or any electronic device) as a sole method of navigation; paper maps, compass and navigation skills are still the best!
3 Likes