1:1 aspect ratio lost between iOS 13 Photos and Photos in High Sierra

A little more followup - “engineering” from the Media and Services group is looking at my Photostream account - they had me take snapshots of photo/cloud storage on phone, iPad, and computers and I’m waiting to hear back. My theory is that part of this is the result of ios 13 photostream retaining 1 month of photos vs previous systems let you keep 1000 photos…however this is different than the image size issue i’m having a problem with. For photostream to work - you need two conditions -be on wifi and the camera app to be closed(this new to me_ i never needed to quit the camera before ios 13) I’ve feeded back before that it would nice to have a ‘push to photstream’ button. SO I wait for a response but i don’t have any illusions about solutions. -Oh - and the investigating engineering team shut down my machine the other morning without warning me beforehand. (I gave them access to pursue this issue) - which is totally bad form and i sent a complaint to my contact. That’s all for now.

Support Agent called today and verified that my issues with devices uploading to photostream works again. It does, but she said the engineering team will now work on why My 1:1 Camera images from the new SE 2 don’t maintain square image in photostream or upload properly on sub Catalina systems. With today’s HEIC post at tidbits, I wonder if there an issue with the ‘save’ data reading to photostream or How old Photos import read Images files (ignoring the format). Maybe we’ll see. Stay tuned. - b

More to report- Photostream still flaky - I sent to Apple a bunch of test images and a screen movie of shooting them as 1:1 - The apple rep i talk to told me that photstream images can take up to 24 to upload…(make sure the camera is off and you’re on wifi - I expressed that this was not my general experience (to wait hours for PS upload) before iPhone SE2 (or ios 13) - I also sent my contact a video link of my vimeo movies made from square format iPhone images. It’s not bs that i prefer the square format.
I won’t get a response back at least until sunday - unless Apple engineer tries to get in touch with me- although I"d prefer Eddie Cue contact me directly!

I attached this note with the images :

Dear Apple Engineer.,

Here are photos I took with the help of A------.

Photostream Uploading is not fixed!!

Photostream took a LONG time to send these images to the cloud…I’m not happy! (I love my apple stuff but this seriously impedes my workflow and production process.)

Some Detail -

Separately Uploaded

Screen-movie of iPhone SE2 taking 4 square (1:1) shots of my living room - (weds)

-Zipped -

the 4 shots from the phone, and 1 shot of the Charles River from a walk after my phone all with Ashley (as a square)

a screenshot of my catalina PS /Macbook Air (which had NO new photostream images-) (thursday am)

a screenshot of my (main) High Sierra Workstation iMac photostream - showing non square images. (thursday AM)

I can be reached at lowengard@mac.com

Thanks !

Benjamin Lowengard

7/8/20 - -Once again they requested images from me - which i sent, once again they said i won’t hear back from my contact since she’s not back in the office til sunday (Oh and i had to ask about this, this week) I included a new note with my images:

Hey Apple ____,

A____ called and asked to send another sample of original photo and what i get when it moves to photostream…see my files (which i created yesterday) .

Let me reiterate my configuration (i was an ASPN/ACN Apple Consultant in the 90s/2000s) my configuration is 1 iPhone SE2, I iPad mini 2, I MacBook air with Catalina, iMac with High Sierra - all in the same network with the same apple id and my default photo configuration is 1:1 with HEIC off.

Import into Catalina yield correct image but photstream does not…
I do not use catalina as my main machine (a previous Support person told me to switch to it !!) I will not use Catalina as my main machine for a while, even longer now that Apple has changed to ARM.

The results have been consistent since the purchase of this iPhone SE2 and not beforehand (which was an iPhone 6) . That implies to me -something about the way the camera saves these images is at the root of this issue.

Feel free to ask questions.


I"m a little disappointed in how many times I’ve had to relate my issues and provide examples. I have not talked to an engineer, just a support contact who keeps apologizing. Sorry to keep this thread going - i was hoping a solution not a TBC note …, best, benj

I too am using High Sierra, iOS 13, Camera in 1:! and Photostream. But I’m seeing different issues (Photostream deciding that photos are “new” months after they are captured and streaming them again.)

But my advice is to put your energy into finding another workflow. Apple is very unlikely to issue anything but security and critical fixes for High Sierra at this point. Personally, I have adapted to relying more on Amazon Photos than Photostream.

I don’t have high expectations, one senior advisor inferred that photostream and(!!!) match are on the way out. I’m not doing anything different than I did with an iPhone 6. Harrumph! (I’m over 60, I’m allowed to grumble. )

Since new Apple IDs don’t get Photo Stream, it cannot be too surprising that it’s on the way out. Match is less clear.

I thought It was moved to photos/prefs/cloud in Catalina. And I set up a photo stream for a customer with a new Apple ID very recently, but not Catalina.It worked great. So I’m not sure if this is the case. It’s not that Photostream isn’t working but that it’s not working properly.

On page https://support.apple.com/en-us/HT201317 “My Photo Stream” Apple warns:
“If you recently created your Apple ID, My Photo Stream might not be available. If My Photo Stream isn’t available, use iCloud Photos to keep your photos and videos in iCloud.”
It has said the same thing since at least February, and I think a lot longer.

I’ve been interpreting that as saying that Apple IDs created after some point in the past don’t get to use My Photo Stream. If your customer really had a new Apple ID, maybe the warning means that it takes a while for an Apple ID to be eligible for My Photo Stream, or maybe it means that they intend to stop supporting it for new users at some point.

For my customer Photostream -worked. This is clearly unclear policy. (aren’t you glad this thread is here to suss it out?) Paging Eddie Cue. ?

I’m not in the dev program anymore so I have to go this route.
Stay tuned…

-b

Benjamin Lowengard
lowengard@mac.com
617.584.1671