Issues with Apple Mail and Gmail in HS

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

Issues with Apple Mail and Gmail in HS

Norm Harris
Recently upgraded to High Sierra from… Embarrassingly ;) LOL ….. From Yosemite.

I’ve been experiencing several “issues” since doing so. Curious if this matches others experience.

1. Searching in Apple Mail for a specific message or messages appears to miss many more messages than in Yosemite.

2. I am a frequent user of “flags” in Apple Mail. But with High Sierra, the messages are sometimes staying in my “flag” folder after I “unflag” them. I’ll try relaunch and flag and unflag and even flag and unflag on Gmail web page but no luck.

3. On startup, Apple Mail is now often showing the “not connected” icon next to the Inbox mailbox. Never experienced that previously. It connects within a minute or less but wondering if there is something else amiss.

The first issue is very frustrating and I’ve now started to go to the Gmail web page and search there. That works or at least it produces many more “hits” with same search terms. Whether 100% who knows.

Thanks for any info.


____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Apple Mail and Gmail in HS

@lbutlr
On 22 Nov 2017, at 17:51, Norm Harris <[hidden email]> wrote:
> 1. Searching in Apple Mail for a specific message or messages appears to miss many more messages than in Yosemite.

Searching for me is better in High Sierra, though it's always been good. This might be a time to force the indexes to rebuild.

> 2. I am a frequent user of “flags” in Apple Mail. But with High Sierra, the messages are sometimes staying in my “flag” folder after I “unflag” them. I’ll try relaunch and flag and unflag and even flag and unflag on Gmail web page but no luck.

This has been reported (I think on this list) by others. I don't see it, but I use flags rarely to keep track of messages that have important information I will need to refer back to (usually code snippets or step-by-step directions)

> 3. On startup, Apple Mail is now often showing the “not connected” icon next to the Inbox mailbox. Never experienced that previously. It connects within a minute or less but wondering if there is something else amiss.

I don't think so, it's just much better about reporting when it's not really connected.

--
Apple broke AppleScripting signatures in Mail.app, so no random signatures.




____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Apple Mail and Gmail in HS

Alexander Forbes
On Nov 23, 2017, at 9:42 AM, @lbutlr <[hidden email]> wrote:

3. On startup, Apple Mail is now often showing the “not connected” icon next to the Inbox mailbox. Never experienced that previously. It connects within a minute or less but wondering if there is something else amiss.

I don't think so, it's just much better about reporting when it's not really connected.

Agree. I have seen this infrequently over the years on Comcast and Cox, Mac and PC, mail and browser. Unless you are getting a spinning beach ball, the problem may be anywhere else between you and the website or mail host, or the source server itself. The hiccup usually lasts a coupe of seconds or so in my experience, unless a local cable is out somewhere, and connection is restored.




____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Apple Mail and Gmail in HS

Randy B. Singer
In reply to this post by Norm Harris

On Nov 22, 2017, at 4:51 PM, Norm Harris wrote:

> 1. Searching in Apple Mail for a specific message or messages appears to miss many more messages than in Yosemite.

I've heard a bunch of reports that Macs with SSD's (and thus are upgraded automatically to APFS) are having big problems with Spotlight indexing.  That is probably reflected in any problems you have in Mail that involve accessing Spotlight's index.

___________________________________________
Randy B. Singer
Co-author of The Macintosh Bible (4th, 5th, and 6th editions)

Macintosh OS X Routine Maintenance
http://www.macattorney.com/ts.html
___________________________________________






____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Apple Mail and Gmail in HS

Mike Noonan-2
In reply to this post by Norm Harris
I may have first hand knowledge about this.  Look under the Mail View and find Disable Message Filter.  Press it and Read mail appears. 

But there are other ramifications:
- when you add a new mail account (mine Yahoo and Gmail iMap) all folders are toggled to Enable Message Filter.  
- There is no master toggle to turn this off.  You must do it folder by folder.

I sent a Bug report to Mail support.   https://www.apple.com/feedback/mail.html and said this was a bug and not a feature enhancement.
- there are 5 Hide/Show toggles under View.  Why was Enable/Disable used? I suggested that whoever green lighted this dumb function should be taken out back to have a stern talking to.
- parsing Enable/Disable  Message Filter
   to            Hide/Show      Read       Mail     Notice the reversals of meaning 
- what has happened to Apple GIU standards?
- who wanted this function?  two people?

I spent well over twenty hours before I stumbled onto this right in the middle of a big construction project where I was juggling five contractors and the three hovering managers. 

If you find this function misguided, please let Mail Support know. 

HTH is your fix. Mike


On Nov 22, 2017, at 4:51 PM, Norm Harris <[hidden email]> wrote:

Recently upgraded to High Sierra from… Embarrassingly ;) LOL ….. From Yosemite.

I’ve been experiencing several “issues” since doing so. Curious if this matches others experience.

1. Searching in Apple Mail for a specific message or messages appears to miss many more messages than in Yosemite.

2. I am a frequent user of “flags” in Apple Mail. But with High Sierra, the messages are sometimes staying in my “flag” folder after I “unflag” them. I’ll try relaunch and flag and unflag and even flag and unflag on Gmail web page but no luck.

3. On startup, Apple Mail is now often showing the “not connected” icon next to the Inbox mailbox. Never experienced that previously. It connects within a minute or less but wondering if there is something else amiss.

The first issue is very frustrating and I’ve now started to go to the Gmail web page and search there. That works or at least it produces many more “hits” with same search terms. Whether 100% who knows.

Thanks for any info.


____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____




____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Apple Mail and Gmail in HS

Jerome King-2
I am running HS and Mail is v 11.1.  I have NO "Disable Mail Filter" option under the view tab in Mail

Jerry

On Nov 23, 2017, at 9:13 PM, Mike Noonan <[hidden email]> wrote:

I may have first hand knowledge about this.  Look under the Mail View and find Disable Message Filter.  Press it and Read mail appears. 

But there are other ramifications:
- when you add a new mail account (mine Yahoo and Gmail iMap) all folders are toggled to Enable Message Filter.  
- There is no master toggle to turn this off.  You must do it folder by folder.




____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Apple Mail and Gmail in HS

Bill Guion
Try selecting a mailbox on the left hand side, then pull down the view menu.

     -----===== Bill =====-----

On Nov 24, 2017, at 10:40 AM, Jerome King <[hidden email]> wrote:

I am running HS and Mail is v 11.1.  I have NO "Disable Mail Filter" option under the view tab in Mail

Jerry

On Nov 23, 2017, at 9:13 PM, Mike Noonan <[hidden email]> wrote:

I may have first hand knowledge about this.  Look under the Mail View and find Disable Message Filter.  Press it and Read mail appears. 

But there are other ramifications:
- when you add a new mail account (mine Yahoo and Gmail iMap) all folders are toggled to Enable Message Filter.  
- There is no master toggle to turn this off.  You must do it folder by folder.



____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____




____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Apple Mail and Gmail in HS

Alan Forkosh
This is way to deal with this. without pulling down the View menu.  Check the header above the message list. On the left is a ’Sort by’ dropdown where you can select the field and direction for sorting the list. On the right is the filtering icon, a circled, centered list icon. If you are not filtering, that is what you see. If you click it, it will highlight and the text ‘Filtered by…’ will appear. Again the last word is actually a dropdown menu and you can select the relevant status. But if you want to see all messages, just click the icon and filtering will be turned off.

Alan Forkosh                    Oakland, CA
[hidden email]
http://al4kosh.com



On Nov 24, 2017, at 10:14 AM, Bill Guion <[hidden email]> wrote:

Try selecting a mailbox on the left hand side, then pull down the view menu.

     -----===== Bill =====-----

On Nov 24, 2017, at 10:40 AM, Jerome King <[hidden email]> wrote:

I am running HS and Mail is v 11.1.  I have NO "Disable Mail Filter" option under the view tab in Mail

Jerry

On Nov 23, 2017, at 9:13 PM, Mike Noonan <[hidden email]> wrote:

I may have first hand knowledge about this.  Look under the Mail View and find Disable Message Filter.  Press it and Read mail appears. 

But there are other ramifications:
- when you add a new mail account (mine Yahoo and Gmail iMap) all folders are toggled to Enable Message Filter.  
- There is no master toggle to turn this off.  You must do it folder by folder.






____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Apple Mail and Gmail in HS

Jeffrey Jones-2
In reply to this post by Jerome King-2
If the filter is already disabled, then the menu item is "Enable Mail Filter". Keyboard shortcut Command-L.

(I'm still at Sierra, but I doubt this has changed.)

> On Nov 24, 2017, at 10:40 AM, Jerome King <[hidden email]> wrote:
>
> I am running HS and Mail is v 11.1.  I have NO "Disable Mail Filter" option under the view tab in Mail




____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Apple Mail and Gmail in HS

Jerome King-2
In reply to this post by Bill Guion
Im in Classic view. That may be the reason. 
But selecting the Inbox doesn’t offer up the mail filter option. 
I think that Classic is the difference



On Nov 24, 2017, at 1:14 PM, Bill Guion <[hidden email]> wrote:

Try selecting a mailbox on the left hand side, then pull down the view menu.

     -----===== Bill =====-----

On Nov 24, 2017, at 10:40 AM, Jerome King <[hidden email]> wrote:

I am running HS and Mail is v 11.1.  I have NO "Disable Mail Filter" option under the view tab in Mail

Jerry

On Nov 23, 2017, at 9:13 PM, Mike Noonan <[hidden email]> wrote:

I may have first hand knowledge about this.  Look under the Mail View and find Disable Message Filter.  Press it and Read mail appears. 

But there are other ramifications:
- when you add a new mail account (mine Yahoo and Gmail iMap) all folders are toggled to Enable Message Filter.  
- There is no master toggle to turn this off.  You must do it folder by folder.



____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____



____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____




____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Apple Mail and Gmail in HS

James R Cutler
In reply to this post by Alan Forkosh
All,

Alan’s solution is perfect if one is NOT using Classic View.  The filter icon does NOT appear in Classic View, which is preferred by many of us.

Jim

On Nov 24, 2017, at 12:27 PM, Alan Forkosh <[hidden email]> wrote:

This is way to deal with this. without pulling down the View menu.  Check the header above the message list. On the left is a ’Sort by’ dropdown where you can select the field and direction for sorting the list. On the right is the filtering icon, a circled, centered list icon. If you are not filtering, that is what you see. If you click it, it will highlight and the text ‘Filtered by…’ will appear. Again the last word is actually a dropdown menu and you can select the relevant status. But if you want to see all messages, just click the icon and filtering will be turned off.

Alan Forkosh                    Oakland, CA
[hidden email]

On Nov 24, 2017, at 10:14 AM, Bill Guion <[hidden email]> wrote:

Try selecting a mailbox on the left hand side, then pull down the view menu.

     -----===== Bill =====-----

On Nov 24, 2017, at 10:40 AM, Jerome King <[hidden email]> wrote:

I am running HS and Mail is v 11.1.  I have NO "Disable Mail Filter" option under the view tab in Mail

Jerry

On Nov 23, 2017, at 9:13 PM, Mike Noonan <[hidden email]> wrote:

I may have first hand knowledge about this.  Look under the Mail View and find Disable Message Filter.  Press it and Read mail appears. 

But there are other ramifications:
- when you add a new mail account (mine Yahoo and Gmail iMap) all folders are toggled to Enable Message Filter.  
- There is no master toggle to turn this off.  You must do it folder by folder.





____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____




____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Apple Mail and Gmail in HS

Jerome King-2
In reply to this post by Alan Forkosh
per prior reply. I use Classic so miss the "benefits" of new Mail
I’m happy and should remember to not comment 

JWK

On Nov 24, 2017, at 1:27 PM, Alan Forkosh <[hidden email]> wrote:

This is way to deal with this. without pulling down the View menu.  Check the header above the message list. On the left is a ’Sort by’ dropdown where you can select the field and direction for sorting the list. On the right is the filtering icon, a circled, centered list icon. If you are not filtering, that is what you see. If you click it, it will highlight and the text ‘Filtered by…’ will appear. Again the last word is actually a dropdown menu and you can select the relevant status. But if you want to see all messages, just click the icon and filtering will be turned off.

Alan Forkosh                    Oakland, CA
[hidden email]

On Nov 24, 2017, at 10:14 AM, Bill Guion <[hidden email]> wrote:

Try selecting a mailbox on the left hand side, then pull down the view menu.

     -----===== Bill =====-----

On Nov 24, 2017, at 10:40 AM, Jerome King <[hidden email]> wrote:

I am running HS and Mail is v 11.1.  I have NO "Disable Mail Filter" option under the view tab in Mail

Jerry

On Nov 23, 2017, at 9:13 PM, Mike Noonan <[hidden email]> wrote:

I may have first hand knowledge about this.  Look under the Mail View and find Disable Message Filter.  Press it and Read mail appears. 

But there are other ramifications:
- when you add a new mail account (mine Yahoo and Gmail iMap) all folders are toggled to Enable Message Filter.  
- There is no master toggle to turn this off.  You must do it folder by folder.





____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____




____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Apple Mail and Gmail in HS

@lbutlr
In reply to this post by Randy B. Singer
On 23 Nov 2017, at 15:22, Randy B. Singer <[hidden email]> wrote:
> I've heard a bunch of reports that Macs with SSD's (and thus are upgraded automatically to APFS) are having big problems with Spotlight indexing.

I haven't seen any issues on 5 SSD High Sierra.. no, wait, sorry, 6 SSD High Sierra machines. Spotlight in Mail.app is fast and, AFAICT, reporting all appropriate results.

>  That is probably reflected in any problems you have in Mail that involve accessing Spotlight's index.

There are about 100,000,000 active Macs out there (meaning they are running a supported version of the OS). Unless you are hearing tens of thousands of people complaining, this can't be a widespread problem.

One thing that I've found makes a larger than usual difference with High Sierra is doing a shift-boot.

(Just boot the machine with the Shift key down, login, and restart).

On 23 Nov 2017, at 19:13, Mike Noonan <[hidden email]> wrote:
> - there are 5 Hide/Show toggles under View.  Why was Enable/Disable used?

Because enabling the filters exposes a new UI element with many options, while the View/Hide options are a simple toggle.

--
Apple broke AppleScripting signatures in Mail.app, so no random signatures.




____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____
Reply | Threaded
Open this post in threaded view
|

Re: Issues with Apple Mail and Gmail in HS

@lbutlr
In reply to this post by Jerome King-2
On 24 Nov 2017, at 08:40, Jerome King <[hidden email]> wrote:
> I am running HS and Mail is v 11.1.  I have NO "Disable Mail Filter" option under the view tab in Mail

Then you have "Enable Mail Filter"

<https://www.dropbox.com/s/yqd0fwcbmets6p4/Screenshot%202017-11-24%2020.34.26.png?dl=0>

<https://www.dropbox.com/s/1za0dkllyh70va0/Screenshot%202017-11-24%2020.38.55.png?dl=0>

--
Apple broke AppleScripting signatures in Mail.app, so no random signatures.




____________TidBITS Talk Participation Guidelines____________
Post only when you have something substantive to contribute.
Be polite and constructive, and comment on posts, not people.
Quote sparingly, if at all. We all read the previous message.
Start threads with a new message to [hidden email].
Read archives at: http://tidbits.com/pipermail/tidbits-talk/
Unsubscribe at: http://tidbits.com/mailman/options/tidbits-talk
____Mailing List Manners: http://tidbits.com/series/1141 ____